
Congressional Help Introduction  •  1 

XMetaL-Help 

Drafting Legislative 
Document 

 
 
 
 

 
 

By Legislative Computer Systems, Office of the Clerk 

August 12, 2004 



Congressional Help Introduction  •  2 

 
CONTENTS 

INTRODUCTION ..............................................................................................................................................................4 
ABOUT THIS DOCUMENT ..................................................................................................................................................4 
XML AND XMETAL.........................................................................................................................................................4 
HELP.................................................................................................................................................................................7 
PROVIDING USER FEEDBACK............................................................................................................................................7 
SOFTWARE UPDATES ........................................................................................................................................................8 

WORKING WITH FILES.................................................................................................................................................9 
CREATING A NEW FILE ....................................................................................................................................................9 
OPENING AN EXISTING XML DOCUMENT .......................................................................................................................11 
SETTING PERSONAL EDITING PREFERENCES ....................................................................................................................11 
WORKING WITH SENATE FILES.......................................................................................................................................13 
SAVING A DOCUMENT.....................................................................................................................................................13 
PRINTING A DOCUMENT ..................................................................................................................................................14 
CLOSING A DOCUMENT ...................................................................................................................................................14 
WORKING OFFLINE.........................................................................................................................................................14 

WORKING WITH XML.................................................................................................................................................17 
TEXT-INSERT MARKERS .................................................................................................................................................20 
GENERATED TEXT ..........................................................................................................................................................21 
CONVERTING FILES TO XML..........................................................................................................................................21 
MERGING XML FILES ....................................................................................................................................................30 
USING CONVERTED XYWRITE FILES FROM PRIOR CONGRESSES .....................................................................................33 

NAVIGATING AND VIEWING DOCUMENTS..........................................................................................................36 
THE CONTEXT AREA ......................................................................................................................................................36 
MOVING BETWEEN DOCUMENTS....................................................................................................................................36 
BASIC NAVIGATION........................................................................................................................................................37 
LARGE DOCUMENT NAVIGATION ...................................................................................................................................38 
THE GO MENU................................................................................................................................................................39 

THE PRE-FORM AND BILL HEADER .......................................................................................................................40 
THE HOLC PRE-FORM ....................................................................................................................................................40 
THE FORM OR BILL HEAD ................................................................................................................................................45 

DRAFTING LEGISLATIVE LANGUAGE...................................................................................................................50 
LEGISLATIVE STYLES .....................................................................................................................................................50 
SECTION TYPES ..............................................................................................................................................................55 
WORKING WITH TEXT.....................................................................................................................................................57 
WORKING WITH RESOLUTIONS .......................................................................................................................................59 
CREATING LEVELS..........................................................................................................................................................60 
WORKING WITH LEVELS.................................................................................................................................................62 
PROMOTING AND DEMOTING LEVELS.............................................................................................................................65 
DELETE, CUT, COPY AND PASTE.....................................................................................................................................72 
WORKING WITH QUOTED MATERIAL..............................................................................................................................76 
TABLE OF CONTENTS......................................................................................................................................................80 
ADDITIONAL DRAFTING TOOLS......................................................................................................................................89 
SPECIAL TEXT AND CHARACTERS ..................................................................................................................................98 

WORKING WITH TABLES.........................................................................................................................................100 
XMETAL TABLES OVERVIEW.......................................................................................................................................100 
USING THE TABLE CREATION INTERFACE.....................................................................................................................118 



Congressional Help Introduction  •  3 

TABLE CUSTOMIZATION IN THE TABLE CREATION FORM.............................................................................................129 
TABLE PROPERTIES.......................................................................................................................................................135 
COLUMN OVERVIEW.....................................................................................................................................................156 
ADVANCED FEATURES .................................................................................................................................................160 
TEMPLATE UTILITIES....................................................................................................................................................167 
KNOWN ISSUES.............................................................................................................................................................183 
LEADERING CONDITIONS..............................................................................................................................................186 

STAGES, STAR PRINTS, AND SUSPENSIONS .......................................................................................................187 
STAGES OF LEGISLATION ..............................................................................................................................................187 

CLEANING UP DOCUMENTS ...................................................................................................................................191 
SPELLING/DICTIONARY ................................................................................................................................................191 
THESAURUS ..................................................................................................................................................................192 
TAGGING TERMS ..........................................................................................................................................................194 
CONVERTING HYPHENS TO EN-DASHES.........................................................................................................................194 
FINAL MACROS ............................................................................................................................................................195 

SPECIAL FEATURES...................................................................................................................................................197 
THE RESOURCE MANAGER ...........................................................................................................................................197 
U.S.C. CITATIONS ........................................................................................................................................................202 
MATH FUNCTIONS ........................................................................................................................................................203 
INTERNAL CROSS-REFERENCES....................................................................................................................................205 

APPENDIX A – FAQ .....................................................................................................................................................211 
FREQUENTLY ASKED QUESTIONS .................................................................................................................................211 

APPENDIX B – DEVIANT QUOTED BLOCK STYLES..........................................................................................214 
DRAFTING THE RAILROAD RETIREMENT ACT AND CHAPTER 110 OF TITLE 18 IN XML. ..............................................214 

GLOSSARY OF TERMS ..............................................................................................................................................217 
 
 



Congressional Help Introduction  •  4 

Introduction 

About This Document 
This document accompanies the United States House of 
Representatives XML Legislative application currently in development 
by the Legislative Computer Systems division of the Office of the 
Clerk. 
This application is in use by the Office of House Legislative Counsel 
and the Office of the Clerk.  Due to the unique job functions and 
workflow systems in place in each organization, there may be different 
instructions to complete the same task in this document. 
This project, which originated out of the Bills, Resolutions, and 
Amendments XML Feasibility Study, follows the directive given by 
the Committee on House Administration in a letter dated, November 
20, 2000 to the House Clerk. 

For more information please visit the following sites: 

Bills, Resolutions & Amendments:http://clerkcap.house.gov/xmlholc 
(House Users) 

XML Technical Committee:  http://clerkcap.house.gov/xmltech/s 

XML and XMetaL 
"I am amazed how easy XML is once I read the manual and worked on 
a bill."  Attorney, House Office of Legislative Counsel July 2, 2002 
XMetaL is the windows-based replacement software application for 
XyWrite, a word processing system that the House Office of 
Legislative Counsel (HOLC), the Office of the Clerk, the Government 
Printing Office (GPO) and other organizations use to draft and prepare 
legislation.  HOLC uses a separate program, called DocuComp, to 
print documents created with XMetaL.  DocuComp, in turn, runs a 
GPO composition program called MicroComp that uses the GPO 
Locator Code (XyWrite) system. To facilitate backward compatibility 
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with the GPO Locator Code (XyWrite) System, all documents in 
XMetaL can be saved in GPO Locator Code (XyWrite). 
Historically, authors of all kinds have been responsible for both the 
content and typographical format of paper documents. With the 
introduction of the World Wide Web (WWW), organizations are now 
struggling with their ability to deliver documents in at least two media, 
printed paper and electronically on the WWW, without retyping the 
content. Because of this, a paradigm shift in document creation 
processes are taking place throughout the world. 
XML (Extensible Markup Language) represents the next step in the 
evolution of electronic creation, storage, and delivery of information.  
XML eases the burden organizations encounter when rendering 
documents on multiple media, such as paper and the Web by 
separating the contents of a document from how it will be formatted 
for printing and display. 
XML provides three important benefits: 

• The same source file can be used to format a document for 
presentation on paper, the Web, or other medium. This 
capability eliminates the need to retype, reformat, or 
convert the data; 

• Authors and document creators can concentrate on content 
and the meaning of that content and less on the format or 
the specific presentation medium of a document; 

• Structured-based electronic searches within and across 
documents provide syntax that is more precise for limiting 
searches to specific parts of a document. For example, in 
order to find "tax" in the official title of all 106th 
Congressional bills in XML, the search engine performs a 
search in the <official-title> elements only. 

In terms of drafting legislation using XML, the official paper version 
of a particular bill constitutes, hereby, a representation of that bill, 
albeit the official one. However, the establishment of XML as a 
standard for authoring represents a commitment that legislation is not 
merely ink on paper—it is also information. Our implementation of 
XML using XMetaL does not require you to know the details of XML 
tags (elements) or structures. However, it will be useful for you to 
have an overview of general XML concepts. In fact, the software 
developers at Legislative Computer Systems (LCS) have attempted to 
hide the XML and its element (tags) from your view when working in 
XMetaL. 
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XML is a standards-based computer language designed to describe 
information using your text and content identification tags. XML uses 
tags similar to HTML (Hypertext Markup Language); however, the 
organization or community that is using XML in a given 
implementation defines XML tags. The legislative community (the 
House, the Senate, GPO and the Library of Congress), created the 
names of the elements or tags you will be using to draft legislation. 
The following example shows you how your content can be identified 
using XML tags.  A tag named <official-title> is added to the 
beginning and end of a sentence to describe the contents: 
<official-title>To repeal the provision of the September 11th Victim 
Compensation Fund of 2001 that requires the reduction of a claimant’s 
compensation by the amount of any collateral source compensation 
payments the claimant is entitled to receive, and for other 
purposes.</official-title> 
XML editing using XMetaL is not like word processing in Microsoft 
Word or Corel WordPerfect.  Word processing software attempts to 
provide intelligent assistance to authors in the editing process (e.g., 
spell checkers, rudimentary paragraph numbering, etc.) and support 
free-form word processing.  As you can see in this example, all content 
marked with the <official-title> tag is displayed twice in the document 
with different formatting.  In XMetaL, the author only typed the 
official title once. 

 



Congressional Help Introduction  •  7 

As you learn to author legislation in XMetaL, you will discover that 
XMetaL goes beyond what can be achieved in a word processor.  An 
XML document is based on pre-defined tags and formatting rules that 
provide an intelligent editing environment for drafters and you will be 
able to concentrate on writing content, not on formatting the 
presentation of your documents. 

Help 
If you need assistance using XMetaL, please contact Legislative 
Computer Systems in the House Office of the Clerk at 225-8484.  This 
document is also posted on the web at 
http://clerkcap.house.gov/xmlholc. 

Providing User Feedback 
You are encouraged to provide comments to LCS regarding XMetaL.  
To do so, please send an email to XML_HOLC@mail.house.gov, or 
via the Internet by selecting HOLC Feedback Form from the Help menu. 
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Software Updates 
XMetaL customizations for Legislative Documents are an on-going 
process. Occasionally you will be asked to update the licensed copy of 
XMetaL installed on your desktop PC. 
Please follow these simple steps to update your XMetaL application 
when needed: 

• Close XMetaL if it is open; 

• Double click on the XMetaL User Update Icon on your 
PC’s desktop. 

o [If XMetaL is open, you will be asked to close it. Close and 
click OK. Wait ten seconds and double click on the User Update Icon 
again.] 

• The update will perform a series of automatic steps. Do not 
respond to the dialog boxes while the update is running. 
The update program will respond automatically. (Due to 
the different speeds of some computers, it may take a few 
seconds for the program to respond automatically.) 

• Click OK on the dialog box that says "Update is 
Complete…Don't forget to print out a new copy of the user 
documentation. Click OK to exit." 

• Open XMetaL and resume working. 
If you have any questions or problems during an update, please contact 
your office's liaison to Legislative Computer Systems (LCS) or contact 
LCS directly at 202-225-8484. (For laptop users, please contact your 
office's system administrator for instructions on how to update.) 
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Working with Files 

Creating A New File 
Follow these steps to create a new file: 

• Open XMetaL. Select New from the File menu, or press 
CTRL+N; 

• The File New dialog box will appear; 

 
• Select the sponsoring Member by using the drop down box, 

or type the first few letters of the Member's last name. 
Select the Attorney/Staff name in the same manner; 

• Go back to the top of the dialog box; select a document 
type by using the drop down box; 

• Select the form or style for the bill or resolution by using 
the drop down box on the right.  

Please see Legislative Styles for more information 



Congressional Help Working with Files  •  10 

• Select where your document will be stored by clicking the 
Member, User, or Other radio button: 

o If you select Member, the file is stored on the F:/M8 directory 
in a folder with the Member’s last name; 
o If you select user, the file is stored on the F:/ directory in a 
folder by the user’s initials; 

 

o If you select “other”, a windows dialog appears that allows you 
to specify a storage folder for your new document that is located on 
your network or hard drive; 

 HOLC ONLY:  Please contact HOLC IT Support if a Member name does not appear on the pull down list, 
or if a folder does not exist for the selected Member. IT ADMINISTRATORS: Refer to the section on 
“Administrative Actions” to update or change the drop-down lists in the File/New dialog box. 

• Insert a name for the file (optional). You may use the 
default document name.  Continue down the dialog box and 
select the subfolder, if necessary; 

• For bills (optional): Click on Short Title check box to add 
the short title.  Enter additional text in the adjacent field if 
needed; 

• Click on the Create Document button. 

When the File/New dialog box is open, the TAB key may be used to navigate from field to field.  SHIFT+TAB 
moves through the fields in reverse order.  The field that is currently in focus will either be: highlighted, the drop-
down list activated, the cursor will be visible in the active fields, or the button will be outlined (if the “field” is a 
button).Pressing the spacebar when the cursor is in the short-title check box will insert (or remove) the check mark. 

 To view a demonstration of File/New, click here. Video 

 To view a list of available tutorials, click here. Video Tutorials (all) 
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Opening an existing XML document 
To open a document: 

• Select Open from the File menu, or press CTRL+O. 
The Open dialog box is a standard Windows open dialog box, and 
operates the same as other Windows applications, such as MS Word. 
 

 To view a demonstration of File/Open, click here. Video Tutorials 
(File/Open) 

 To view a list of available tutorials, click here. Video Tutorials (all) 

Setting personal editing preferences 
You may set how XMetaL displays by selecting font type, size, and 
colors.  You may also set certain keystrokes and preform settings on 
new documents by setting your user preferences. 

• Select Set User Preferences from the Tools menu; 

• Read the file that is opened and follow the instructions to 
change the items as desired; 

• When finished, Save and Close the file. 
To restore the editing preferences to their default values: 

• Select Reset User Preferences to Default Values from the 
Tools menu, or click on the Refresh My Preferences icon on 
the Toolbar. 

It is important to have your particular organization's name or acronym listed under Organization name.  The 
shift period behavior, as well as whether the preform is selected for new documents is determined by the 
organizational preference. 

Setting options in XMetaL 
You may set XMetaL so the last document you worked on opens 
automatically the next time you open XMetaL.   

• Select Options from the XMetaL menu; 

• Under the General tab, check Restore last open documents. 
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Viewing information about a document 
To view information about the current document: 

• Select Document Information from the File menu, or press 
CTRL+D. 

This information includes the location of the file, current drafter, the 
date the document was created, the archive file names, and the number 
of sections within the document.  This is a text file and it may be 
printed. 

Viewing the current location of the cursor 
To view the current location of the cursor while in the legislative body 
(below the enacting or resolving clause): 

• Select Where Am I from the View menu, or press 
ALT+SHIFT+W. 

   

Viewing the document (tags-on and tags-off) 
There are three possible ways to view documents from within 
XMetaL. 

• Normal View  (tags-off view); 

• Tags On View; 

• Plain Text View. 
When starting a new bill, the default view is Normal View.  You 
should expect to do all of your work in Normal View.  Many of the 
features macros do not function properly in Tags On View or Plain 
Text view.   Run all functions and macros while in Normal View (tags-
off) view. 
Different views can be selected in several ways: 

• Select one of the views from the View menu; 

• Select one of the three icons located next to the context 
area of the XMetaL window. 
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You can toggle between tags on and tags off (normal view) using 
Ctrl+Space Bar. 

See "The Context Area" for more information. 

Working with Senate Files 
There may be times that you are working with Senate XML files.  You 
will be able to open those files with XMetaL and work with them the 
same way you do with House XML files.  The big difference you will 
see is in the element/tag names in the pre-form.  Like HOLC, the 
Senate has their own tracking and document management information 
in the pre-form. 
 

Saving a document 
Saving as XML (XMetaL) 
To save the document in XML: 

• Select Save from the File menu, or press CTRL+S. 
If you have several documents open, this feature will allow you to save 
all open documents in one command. 

• Select Save All from the File menu, or press CTRL+Q.   

When a user presses CTRL+Q a pop-up box will display and ask the user if they want to save all documents.  
This pop-up box does not appear when the Save All from the File menu is selected.   

Saving As Locator Codes (XyWrite) 
To save a bill in Locator Codes (XyWrite), select Save As Locator 
Code from the File menu.  Use this option if you need to work with the 
file in XyWrite, otherwise, it is not necessary to save the file as 
Locator Codes (XyWrite). 
If two files exist for one document -- one file saved in XML and one 
file saved in Locator Codes (XyWrite) -- both files are not 
automatically updated if a change is made in one of the existing files. 

 In XyWrite: When opening a file (saved as locator codes) in XyWrite, use CTRL+ALT+Z to "remode" the 
bell codes. 
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Printing a document 
To print an XML file from XMetaL, MicroComp must be installed on 
your computer. 

House Office of Legislative Counsel (HOLC) 
The program DocuComp needs to be installed and running on your 
PC.  To see if DocuComp is running: 

• Go to the Start button, click Programs, and then DocuComp; 
To print (from within XMetaL): 

• Select Print from the File menu, or press CTRL+P. 
The file will close at the time of printing.  This ensures that the 
archiving number is placed correctly in the file.  When the document is 
open, archive information may be viewed by selecting Document 
Information from the File menu.   

• After the file is closed, the file is sent to DocuComp.  Set 
the appropriate setting on the DocuComp window and press 
the GO button.  (For more information on DocuComp and 
its features, contact IT Support in HOLC.) 

Enrolling Clerks, Office of the Clerk, and other House 
Offices: 
In XMetaL: 

• Select Print from the File menu or press CTRL+P. 

Closing a document 
To close a document: 

• Select Close from the File menu or press CTRL+W; 

• Select Close All from the File menu to close all open 
documents. 

Working Offline 
There may be times that you need to work offline (not connected to 
your office’s network).   If you intend to create new files while 
working offline the information and instructions below are important 
in the successful creation on new documents.  If you are working 
offline on a file saved on your laptop, diskette or other storage device, 
there is no need to change your preference settings. 
Automatic detention 
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By default, if your computer loses its connection to the F:/drive or 
your computer is not connected to the network when XMetaL is 
opened, a message will indicate this and  your default directory in your 
user preferences file will be reset  to C:\XML. 

 
When creating new files, the only folder options available are “user” 
and “other”.   Leave the Attorney/Staff Directory as “XML-XML”.  
The files will be created in C:\XML. 
If you would like to include the attorney’s name in the HOLC pre-
form data, use the “Edit Attorney Field in HOLC pre-form” option 
under the LegDocMgt menu. 

 
Manual 
Follow the directions below to manually change your preferences to 
work offline before creating new files. 

• Open the Users Preferences in XMetaL and change the 
setting DefaultDir to C:\; 

• Make sure that a folder named with your initials has been 
created on your laptop’s C drive if you wish to save the 
files you intend to create in your user directory.  Otherwise, 
use the default folder XML. 

• Save and close the User Preferences, and start working by 
creating a new file using File/New. 



Congressional Help Working with Files  •  16 

Other 
If your workstation is remapped to the F:/drive or the connection is 
restored, when XMetaL is open, it will recognize the F:/drive and ask 
if the user preferences should be updated. 

 

If you have been working offline, do not forget to save your file to the network.  This will ensure that it is 
accessible by others in the office and  properly included in network-wide recovery (or back up) routines. 
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Working with XML 

An XML document is valid if it is well-formed and if it conforms to 
the rules in an organization’s DTD (Document Type Definition).  The 
XML elements (or tags) defined in an organization’s DTD are unique 
to that organization.  Congressional bills and resolutions have DTDs 
which have been agreed upon by the Congressional community, 
specifically the Legislative Branch XML Technical Committee.    
For bills and resolutions, the elements (or tags) have specific meanings 
and purposes.  The majority of the tags describe the contents of the 
text they surround.  For instance, the <official-title> tags contain the 
official title of the bill.   
It is important to “tag” your document correctly.  Let’s look at this 
sample language. 
(d) Grade and Pay Scale. – Section 7404(b)(1) of such title is amended 
by striking the third center heading in the table and inserting the 
following: 
 “Clinical Podiatrist, Chiropractor, and Optometrist Schedule”. 
The words “Clinical Podiatrist, Chiropractor, and Optometrist 
Schedule” would need to be tagged with table tags, not table of 
contents tags.  Although the table of contents tags would render (print) 
the text correctly, this is not a table of contents entry.  It is a table. 

See http://xml.house.gov for more information on the DTD’s 
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The Validator 
Use the Validate Document command to verify that your document is 
valid XML.  If the validation process finds an error, a message appears 
and the cursor can be moved to the error, so it can be fixed.   
To validate a document manually,  

• Select Validate Document from the Tools menu, click on the 
icon on the toolbar, or press the F9 key. 

One of the following appears: 

• A message box indicating if the document is valid. (The 
message says, “Validation is complete.”); 

• A validation log containing a list of one or more error 
messages.  To go to the location of an error, double-click 
on the error message or single-click on the error message 
and click the go to button. 

 

The Validate Document command runs automatically when the 
document is saved.  If the document is valid, no dialog boxes will 
appear.  If the document is invalid, the Validation Log will appear. 

Common Errors that makes a document invalid 
An Example: Table of Contents 
A common condition with the Table of Contents will cause your 
document to be invalid. 
Let’s say, the drafter did the following: 

• Drafted a bill with seven sections, 

• Generated a Table of Contents for the bill, 

• Deleted one of the seven sections, and 

• Tried to save and print the document. 
At this point, the validation log would appear listing an error message 
that read something like this: 
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“Missing reference ID: Attribute 
IDREF=”H4FE34AE02884AFBAED743874” in tag “toc-entry” has 
no corresponding ID attribute value in document” 
This means that there is a TOC entry for the deleted section, but the 
section no longer exists in the document.  To solve the problem, 
regenerate the table of contents.  By regenerating the table of contents, 
the TOC entry for the deleted section will be removed.  
The table below includes more messages that may occur in the 
validator log. 

Missing reference ID: Attribute 
IDREF=”H4FE34AE02884AFBAED74
3874” in tag “toc-entry” has no 
corresponding ID attribute value in 
document 

A TOC entry does not match any of the 
sections or big levels in the bill.  Most 
likely, this level was deleted during the 
drafting process and the Table of Contents 
needs to be regenerated. 
Each level has its own ID.  The IDRef is the 
number used to link or reference the section 
or big level ID. 

Unknown tag name. The tag name 
“unknown” is not defined 

The tag “unknown” is an unknown tag.  
Delete the tag and its contents. Call LCS for 
assistance. 

Missing referee ID: Attribute 
IDREF=”H43432432” in tag “noted” has 
no corresponding ID Attribute value in 
document 

In the conversion notes, the ID for the level 
that is noted is not available.  Delete the 
conversion note. 
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Text-Insert Markers 
While drafting, certain areas throughout the document are highlighted 
with Text-Insert Markers. These markers are gray in color and contain 
a description surrounded by curly braces. Place the cursor on the 
description and type desired text. These are used to aid you in drafting. 
When the cursor is placed in these markers, the appearance changes to 
a white text on a darker gray background.  (See the marker on the far 
right.) 
The following are examples of the most commonly used Markers: 

    

 To view some text-insert markers, click here. Video Tutorials (text 
markers) 

 To view a list of available tutorials, click here. Video Tutorials (all) 



Congressional Help Working with XML  •  21 

Generated Text 
In XMetaL, generated text, by default, appears gray in color.  
Generated text is used when text must be rendered (or printed) but is 
not itself included in the XML document.  Legislative documents in 
XML contain generated text.  The Enacting Clauses and the words 
“Section” and “Sec” are samples of generated text in bills and 
resolutions. 

 To view some text-insert markers, click here. Video Tutorials 
(generated text) 

 To view a list of available tutorials, click here. Video Tutorials (all) 

Converting Files to XML 
Using locator-coded (XyWrite) files in XMetaL 
These are directions to use the locator-code to XML Conversion 
program written by the House contractor, DataStream Conversion 
Services.  This software will convert both bills and resolutions.  In 
order to know what documents are valid, the software will create two 
folders, labeled “valid” and “invalid”. 

 Before converting your first file, create a folder in your home directory (or another appropriate area) that 
will be used exclusively for converting files. 

Single File Conversion 
Copy the locator-code (XyWrite) file that you want to convert into 
your “special-for-conversion-only” folder (that was created in the step 
above).  
HOLC Only: For files in the M8 (and other M* directories), you must 
copy the files from the M8 directory to your “special-for-conversion-
only” subfolder before running the conversion program.  The M8 (and 
other M* directories) can not be edited and therefore, the new XML 
file created by the conversion program cannot be saved in those 
directories. 
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To open the conversion program: 

• Click on the conversion program icon located on the 
desktop; 

 

• Browse or navigate to the folder that contains the files you 
want to convert to XML.  When you open a folder in the 
box on the left, the middle window will display a list of all 
the files in that folder; 

• Choose one of the following options: 
o Double-click the file you want to convert (displayed in 

the middle window), or; 
o Highlight the file you want to convert, and click the 

Convert to XML button; 

• The window directly above the Convert to XML button will 
show the progress of the conversion, as will the “status” bar 
at the very bottom of the dialog box; 

• Click the Exit button when the conversion is finished. 
The file will be converted and saved with the same name 
(samename.xml) in a subfolder named “valid” or “invalid” in your 
“special-for-conversion-only” (sub) folder. 
The conversion program does not tell you if a file has converted as 
valid or invalid, so when using the files in XMetaL, you will need to 
look in each folder to find the file. 

 INVALID FILES: If your locator-coded file is converted, but it is not a valid XML file, it will be saved in the 
“invalid” folder.  If this occurs, please call Legislative Computer Systems (LCS) at x58484 or seek out the 
appropriate helper in your office.  The invalid XML file needs to be fixed and valid before it can be used or merged 
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into another file.  LCS or your office’s helper can help fix the file, so you can continue working.  Fixing the file may 
take as little as two minutes. 

Converting All Files In A Folder 
To convert all of the files in a folder: 

• Navigate to the folder that contains the files you want to 
convert,  

• Click the Batch Processing button. 

Using Plain Text files in XMetaL  
To convert plain text to XML, use Text2XML.  This feature is located 
on the Tools menu under Text-2-XML (version two), the toolbar, and the 
right-click menu. 
Text2XML Version 2 is a method to convert and paste text selected 
(copied or cut) from non-XMetaL sources into XMetaL.   It will work 
with locator coded material as well as text from Thomas 
(http://thomas.loc.gov or http://www.congress.gov), emails, Word, and 
WordPerfect.  The basic assumption is that the selected text contains 
levels that start on a new line.  
As with the other methods of conversion, this is not a full-proof 
function and the approach does not always work because of problems 
with the selected text or issues the developers have not come across 
yet.  With this caveat in mind, keep the following in mind when using 
this feature: 

• Big levels are not supported (e.g., titles, chapters, parts).  
Work with sections and below; 

• Text2XML will not handle style mistakes or errors. 
Example of a style error: a paragraph followed directly by a 
clause (with no subparagraph). 

The selected material should be structured downward.  That is, the first 
level in the selected material should be the highest level found in the 
selected material to be pasted.  
In addition, the selected material must work structurally in the current 
context. The following examples would not work: 

• If the cursor is in a section with paragraphs and no 
subsections, subsections cannot be added; 

• If the cursor is in a subsection, subitems could not be 
inserted after the subsections. 

The Text2XML feature was designed to convert plain text material 
into a clear spot (e.g., the bottom of the document).  Working at the 
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end of a level and then using Text2XML to paste single or multiples of 
that same level (with or without sublevels) is going to work. 
Although one can paste material into the middle of a document, there 
is one problem that the developers are still looking at: if one try to 
paste between levels that go down (e.g. a section and a subsection), the 
material will be added to the bottom of the higher level (e.g., the 
section). 

Text2XML: Sample Exercises 
Start with a new bill document. 

Sample 1: Simple Example 
Working in an electronic version of this document, select and copy the 
following two paragraphs (3 lines), switch to XMetaL, place the cursor 
in the {header} of the first section, and run the Text2XML feature.    
To run the Text2XML feature: 

• Select Text-2-XML (version two) from the Tools menu. 
(3) This is my first example of Text2XML. 

(4) THIS "IS" THE UNITED STATES.- This "is" text- 

(A) Let's see how a subparagraph will work. 

• Validate the document by pressing the F9 key.  This 
confirms that the document's structure conforms to the 
rules for creating legislation (the Document Type 
Definition or DTD).   

See the Valid XML section for more information using the Validate 
Document command. 

Review the example and note the following: 

• The cursor did not move. 

• The material was inserted into the document with the 
appropriate levels (i.e., 2 paragraphs and a subparagraph).   

• The paragraphs were not renumbered.  This is similar to the 
Merge function.  Staff has requested to see the enumerators 
from the original material and manually renumber when 
ready.   

• The word "is" in both the header and text of paragraph (2) 
is quoted and is quoted correctly. 

Sample 2: Quoted Blocks and Headers 
Working the same document from Sample: 
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• Select and copy the following lines: 
 (1) This is sample 2 and contains a quoted-block. 

"(i) headers end with period dashes.- Text ending with a dash is an em-
dash- 

"(1) Text with some 'quoted text' inside the text   

`(2) Goes- 

``(A) Here.". 

(A) Here's the subparagraph after the quoted-block in sample 2. 

• Switch to XMetaL and place the cursor at the end of the 
last level in Sample 1; 

• Run the Text2XML feature. 
Review the example and note the following: 

• The selected text above is a paragraph with a quoted-block 
and a subparagraph; 

• The subsection in the quoted-block is all lowercased above, 
but it became a header and cased correctly when converted.  
The reason is that the line ends in a point dash (.-) (note one 
or more dashes will work); 

• Quoted-blocks are inserted using the 
quotedblock_defaultstyle value from your preferences (see 
Set User Preferences from the Tools menu), so if the style 
of quoted block needs to be different, change it manually 
by using Set Legislative Style from the Format menu; 

• Paragraph (2) is text and the dash is converted to an em-
dash.  For it to be a header, it needed a point dash; 

• Each of the levels within the quoted-block above begins 
with a different quote mark (it does not matter what it starts 
with); 

• The selection does not go above the top level (paragraph 
(1) This is sample 2 and…).  If the sample contained a 
subsection or a section at the end of subparagraph (A), then 
the selection is said to go above the top level (the paragraph 
(1)) in this example.  Whenever possible, try not to have 
your selected text go above the first level in the selection. 

 To change some or all of the text to be a header after the conversion, select the text in the text element to be 
moved to the header and press Ctrl+H. 
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Sample 3: Getting Non-Quoted-Block Material into 
Quoted-Block 
Using the same XMetaL document from Sample 1 and 2: 

• Select and copy the following lines: 
 (1) This is sample three. 

 (2) THIS "IS" THE UNITED STATES.- This 'is' text- 

 (A) Let's see how a subparagraph will work. 

• Switch to XMetaL: 

• Place your cursor in subparagraph "(A) Here" within the 
quoted-block from Sample 2; 

• Run the Text2XML feature. 
Notice that the two sets of quote marks in paragraph (2) are different. 
Either type work.  

Sample 4: Working With Style Errors/Mistakes  
This sample works with the common problem of incorrect 
enumeration. Text2XML is designed to use the correct enumerators to 
determine the proper level and when the enumerators are wrong, the 
feature will not work.   
Using the same XMetaL document from Sample 1-3: 

• Select and copy the following lines; 
(4) This is sample four. 

(i) If a level is skipped going down, the feature will not work. 

(ii) How could it work? 

(iii) Should these levels be clauses or subparagraphs? 

• Switch to XMetaL; 

• Place your cursor in the paragraph after the quoted-block 
from Sample 3; 

• Run the Text2XML feature. 
The sample is incorrect because  

• it is missing a subparagraph between (4) and (i) or,  

• the levels (i), (ii), (iii) are actually subparagraphs, but they 
are enumerated incorrectly. 

After running Text2XML, an error message indicates that Text2XML 
cannot insert “the (i) If a level… because the parent level is a 
paragraph”. Text2XML assumed that level (i) is not a subsection.  It 
knows this because (ii) has to be a clause. 
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There are several possible solutions to the fixing the text above: 

• The user could fix the text by typing the correct 
enumerators before running Text2XML or, 

• follow the solution in Sample 4A below or,  

• follow the solution in Sample 4B below or 

• follow the solution in Sample 4C below. 

Sample 4A: Designating the Levels inside the Input 
To fix the error from Sample 3, use the same XMetaL document: 

• Select and copy the following lines,  
 (4) This is sample 4A. 

<subparagraph> 

 (i) If a level is skipped going down, the feature will not work. 

 (ii) How could it work? 

 (iii) Should these levels be clauses or subparagraphs? 

</subparagraph> 

• Switch to XMetaL; 

• Place your cursor in the paragraph after the quoted-block 
from Sample 3; 

• Run the Text2XML feature. 
While this sample is small, this solution works well when working 
with a series of paragraphs that have not been enumerator. 

Sample 4B: Bumped Up\ Inline Levels 
To fix the error from Sample 3, use the same XMetaL document: 

• Select and copy the following lines,  
 (4)(A) This is sample 4B.  

 (i) If a level is skipped going down, the feature will not work. 

 (ii) How could it work? 

 (iii) Should these levels be clauses or subparagraphs? 

• Place your cursor in the paragraph after the quoted-block 
from Sample 3; 

• Run the Text2XML feature. 
Look at the example and see how it changed from Sample 4. 
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Sample 4C: Bumped Up\ Inline Levels 
To fix the error from Sample 3, use the same XMetaL document: 

• Select and copy the following lines: 
(4) This is sample 4C. (A) An inline paragraph can make it legal too- 

 (i) If a level is skipped going down, the feature will not work. 

 (ii) How could it work? 

 (iii) Should these levels be clauses or subparagraphs? 

•  Switch to XMetaL; 

• Place your cursor in the paragraph after the quoted-block 
from Sample 3; 

• Run the Text2XML feature. 

LOCATOR CODED MATERIAL AND COMPILATIONS 
Text2XML will also work with locator coded material as well as 
compilations. 
The easiest way to work with locator-coded material is to use Notepad.  
Notepad is a Windows text editor.  One of the nice features of Notepad 
is that you can very quickly see each level on a line by itself.  It is 
sometimes difficult to see inserted line breaks inside Word and 
WordPerfect.  In addition, you do not need to go to DOS to get your 
locator-coded files.  The downside to Notepad is that the special 
characters and colors you normally see in XyWrite look very strange 
in Notepad.   

• To launch Notepad, click the Start button (lower left of 
screen), then select Run, type "notepad" in the dialog box, 
and press Enter. 

Text2XML does not rely on the locator codes (particularly the bell-I 
codes) to determine levels and/or indents. Having said this, the feature 
attempts to convert as much as possible from locator-coded material 
(e.g., em-dashes, en-dashes, en-spaces, fractions, section symbols, 
etc.).  In addition, Text2XML assumes that lines that begin with a bell-
I89 or bell-I74 and are followed by a line that begins with a bell-I20 
(followed by Sec) are traditional section headers.   
For compilations, Text2XML will also automatically eliminate notes, 
reference numbers, and the citations in brackets.  This should make it 
much faster to move compilation material into a bill.   

Additional Questions 
What about Whereas and Resolved clauses? 
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The feature handles those as well within resolutions.  Just select the 
material you need to copy.  You may need to think about where you 
place your cursor because of subsequent sections.  If you want to bring 
in some whereas clauses only, just place your cursor in any of the 
Whereas clauses (or in the resolution's form to paste in at the 
beginning) and the selected ones will be placed after the one where 
your cursor is at.  If you have also selected Resolved clauses or 
sections after the whereas clauses, the cursor needs to be at the last 
whereas clause.   
What about flush-left text? 
Flush-left text is handled.  Sometimes there are going to be problems 
when flush-left text appears between two equivalent levels since that is 
not legal.  This may be particularly an issue when trying to Text2XML 
some compilations material. 
What about indent overrides? 
You have to handle indent overrides manually. 
What about traditional style? 
Traditional style will work when the material was locator coded.  
Otherwise, it does not work.  For non-locator coded material, it is 
difficult to determine whether text that appears without an enumerator 
above a section is flush-left text for the levels above the section or the 
section header.  
What do I do when Text2XML does not work? 
As with all software, especially software as complicated as this, it will 
not work 100 percent of the time, and sometimes, it will probably feel 
like it is not working at all.  Frustrating as this may sound, trying it 
again in the same manner we did it when it failed will not suddenly 
make it work.  Here are some other suggestions: 

• If an error message is displayed, read it carefully.  The 
feature should tell you where the problem is.  It may be that 
level or the next level that is causing the problem.  If you 
get an error message from Text2XML, first perform an 
Undo. Then, paste the material into Notepad and search for 
the text the error message displayed (Ctrl+F).  Then, 
examine and fix at the material with the problem.   

• If you are in a hurry to get the material into XMetaL and 
then you will work on it, use the <level> and </level> 
approach. 

• Select less material to convert.  It helps to work on one 
section or subsection at a time.  This is actually how the 
developers debug problems with Text2XML, but it also 
enables you to get at least some, and hopefully most, of the 
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material into XMetaL.  It also helps to define the exact 
problem causing the problem. 

• Text2XML looks for very specific things to work.  The 
main thing is the enumerator that it expects needs to be at 
the beginning of the line.  It does not matter if there are 
spaces and/or quote marks in front of the enum, but it is 
certainly expecting something in parentheses or (Section, 
SEC., Sec., SECTION, Resolved, RESOLVED, Whereas, 
or WHEREAS).   

• Provide LCS with the files.  Of course, this feature is not 
perfect and probably will never be perfect, but the more 
material and problems we see, the better the software will 
become. 

Merging XML Files 
You can insert material from existing XML files by merging them into 
a new file.  How your text is merged will vary based on the document 
type you are working with. 

 Cursor placement is very important when merging files because how material is inserted is based on 
location. 

To merge XML files: 

• Open, or create, the document that you want to merge other 
XML files into.  Place your cursor in the location where the 
text material should be inserted; 

• Click the Merge icon on the toolbar, Merge Existing XML file 
on the Tools menu, or press CTRL+M; 

A dialog window will appear for you to select the XML files you want 
to merge; 
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• Type a file location and name into the first text box, or 
select a file by clicking the folder icon at the top of the 
screen; 

 

• Click the Official Title checkbox if you want to merge this 
material; 

• Click the Add button, or press ALT+A, to add the file to the 
list of merge documents.  Repeat this process until all the 
files you want to merge are listed in merge box; 

 

• Press the Up and Down arrow buttons to change the order 
that your files will be inserted or appended into the 
document; 

• After all files have been added, click the Merge button. 
The files you have selected will be merged in the following manner: 

Merging Bills 
If a bill is being merged into another bill or resolution: 

• The Official Title will be appended to the current Official 
Title (if you have selected to merge the Official Title); 

• All text below the enacting clause will be inserted based on 
the location of the cursor in the new document. 
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If a bill is being merged into an amendment: 

• An amendment block will be created based on the location 
of the cursor in the new document and all material below 
the enacting clause will be inserted. 

Merging Resolutions 
If a resolution is being merged into another resolution: 

• The Official Title will be appended to the current Official 
Title (if you have selected to merge the Official Title); 

• All where-as clauses will be appended to the preamble; 

• All text after “Resolved” in the resolved clause will be 
inserted as a new section based on the location of the cursor 
in the new document; 

• All remaining material will be inserted after the new 
section based on the location of the cursor in the new 
document. 

If a resolution is being merged into a bill: 

• The Official Title will be appended to the current Official 
Title (if you have selected to merge the Official Title); 

• All text after “Resolved” in the resolved clause will be 
inserted as a new section based on the location of the cursor 
in the new document; 

• All remaining material will be inserted after the new 
section as a new section based on the location of the cursor 
in the new document. 

If a resolution is being merged into an amendment: 

• All text after “Resolved” in the resolved clause will be 
inserted as a new section based on the location of the cursor 
in the new document; 

• A new amendment block will be created based on the 
location of the cursor in the new document and all 
remaining material will be inserted. 
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Merging Amendments 
If an amendment is being merged into an amendment: 

• A new amendment block will be created based on the 
location of the cursor in the new document and all material 
after the amendment form will be inserted; 

If an amendment is being merged into a bill or resolution: 

• All text in the first amendment-block will be inserted as a 
new level based on cursor position. 

Using converted XyWrite files from prior Congresses 
FOR HOLC ONLY: All introduced bills and resolutions drafted in 
Locator Codes (XyWrite) from the 106th, 107th, and 108th 
Congresses have been converted from Locator Codes (XyWrite) to 
XML.  The original Locator Coded (XyWrite) file was obtained from 
the Government Printing Office (GPO).  To use converted files, you 
will merge them into a new document. 
Contact your systems administrator to learn where these files are 
located on your network. 

Please see Merging XML Files for more information. 

Conversion notes and their definitions  
For those converted files that contained technical errors or there were 
problems with the conversion, the file contains conversion notes.  
These conversion notes will not be transferred to the new file (when 
merged); however, during the merge process, an alert will indicate if 
the file contains conversion notes.  If it does, this original converted 
file will open in read-only mode and the conversion notes may be 
viewed through XMetaL’s Resource Manager. 
It is advised to review all conversion notes.  Some of the conversion 
notes will require you to modify the material merged in the new file. 

Conversion Note Definition and Actions 

“No match found for toc-entry 
(Section 1 Used) - " 

In this table of contents, there is not a 
corresponding section.  (Example: HR 10 from the 
106th Congress.)  
Delete the entry and regenerate the table of 
contents. 

“Level may be incorrect for start 
of quoted block” 

The level at the start of the quoted block may be 
incorrect. For instance, if you have a quoted block 
with only a subsection (i), the conversion program 
tags the level as a subsection, but prints the note.  
The conversion program does not know whether 
the level is a clause (i) printed at full margin or 



Congressional Help Working with XML  •  34 

Conversion Note Definition and Actions 
truly subsection (i) in this instance. 
This note gives the drafter the opportunity to 
double-check the level. 

“Empty after-quoted-
block/missing punctuation" 

The punctuation after the close quote for the 
quoted block is missing. (Example: HR 1001 and 
1040 from the 106th Congress.) \ 
Insert the correct punctuation. 

"Can't determine level of header-
in-text" 

The conversion program could not determine what 
type of header this was. (Example: HR 1776 and 
1110 from the 106th Congress.) 
Set the correct attribute for this level. 

"Use of down attribute in indent" 

The conversion program determined that this level 
was to print down from its usual spot. (Example: 
HR 1358 from the 106th Congress)  
Double check to make sure the level is named 
appropriately. 

"Unbalanced double quotes - all 
quotes converted to character 
values" 

The conversion program could not determine 
where the quotes start and end, so they were 
converted to character values (Example: HR 1110 
and 1125 from the 106th Congress.) 
Delete the quotes and insert Quote Tags around the 
material that should be quoted. 

"Unable to convert single quotes 
- character values used" 

The conversion program could not determine 
where the quotes start and end, so they were 
converted to character values (Example: HR 1313 
from the 106th Congress.)  
Delete the quotes and insert Quote Tags around the 
material that should be quoted. 

"Extra mdash at end of header in 
bellcode" 

In the original XyWrite file, there was an extra m-
dash at the end of the header.  It has been removed 
in the converted file. (Example: HR 1776 from the 
106th Congress.) 

"SEC. label missing period - " 

The period following “Sec” was missing from the 
original XyWrite file.  In XML, the period is 
automatically generated due to the standard rules 
of drafting. (Example: HR 1180 from the 106th 
Congress.) 

"SEC. label used for section 1 - " 
In the original XyWrite file, “Sec” was used for 
Section 1. 

"SECTION label used for 
number other than 1 - " 

In the original XyWrite file, “Section” was used 
for a section other than Section 1. (Example: HR 
1523 from the 106th Congress.) 

"Header missing closing period - 
" 

The header in the original XyWrite file was 
missing the closing period.  In XML, the period is 
automatically generated due to the standard rules 
of drafting. (Example: HR 10 and HR 1110 from 
the 106th Congress.) 

"Use of double quotes inside 
quoted-block" 

In the original XyWrite file, double quotes were 
used in the Quoted Block section. In XML, the 
quotes are automatically generated due to the 
standard rules of drafting. (Example: HR 1439 
from the 106th Congress.) 
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Conversion Note Definition and Actions 
"Use of single quotes outside 
quoted-block" 

In the original XyWrite file, single quotes were 
used outside the Quoted Block section.  In XML, 
the quotes are automatically generated due to the 
standard rules of drafting. 
Missing open quotes for level in quoted block 
(Example: HR 10 from the 106th Congress.) 
Missing closing quotes for quoted block (Example: 
HR 1169 from the 106th Congress.) 

"Slug line in bell code not as 
expected -  

(Example: HR 1363 from the 106th Congress.) 

"Found more than one name-id 
for one member: " 

"name-id not found for " 
(Example: HR 1169 from the 106th Congress.) 

“Conversion created mandatory 
element - 

(Example: HR 1391 and HR 1396 from the 106th 
Congress.) 



Congressional Help Navigating and Viewing Documents  •  36 

Navigating and Viewing 
Documents 

The Context Area 
You can determine where your cursor is located in a document by 
looking in the context area.   The context area can be found in the 
bottom left hand corner of the XMetaL window, next to the view 
toolbar, and looks like this: 

 
The context area displays both the current element (tag), as well as its 
ancestors, for your cursor location. 

Moving Between Documents 
If you have more than one document open in XMetaL, you can move 
between the open documents using the Window menu.  If you are in 
Workbook Mode, you can use the View menu. 

View Menu 
If you are in Workbook mode, a tab is displayed with the name for 
each document you have open.  You can navigate from one document 
to another by clicking on the appropriate tab. 

Window Menu 
Use the options below to move between multiple open documents: 

• Select the document you want to work on from the list 
in the Window menu by clicking on the name, or; 

• Click on the Right or Left arrow buttons on the 
Windows toolbar, or; 

• Click Next or Previous on the Windows toolbar, or press 
ALT+ARROW. 
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Basic Navigation 
You can quickly navigate through your document by using the 
keystrokes listed below: 
These keystrokes  Move the cursor 
TAB From element to element, or To the next field 

SHIFT+TAB To the previous field 

LEFT ARROW One character to the left 

RIGHT ARROW One character to the right 

CTRL+LEFT ARROW One word to the left 

CTRL+RIGHT ARROW One word to the right 

UP ARROW Up one line 

DOWN ARROW Down one line 

END To the end of a line 

HOME To the beginning of the document 

PAGE UP Up one screen (scrolling) 

PAGE DOWN Down one screen (scrolling) 

CTRL+END To the end of a document 

CTRL+HOME To the beginning of a document 

CTRL+UP ARROW  One Level Up 

CTRL+DOWN ARROW One Level Down 

ALT+SHIFT+M Set bookmark 

CTRL+ ALT+SHIFT+M Return to bookmark setting 

F4 Return to the previous cursor location after scrolling 
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Large Document Navigation 
You can navigate through your document in several ways, depending 
on how you want to work with them: 
Structure View Navigation 
The structure view is a pane to the left of the document window that 
displays the outline of the document by tagged elements. 
In the structure view you can edit text, and insert, cut, paste, copy, and 
drag-and-drop elements. The selections in the structure view and main 
document view are synchronized. The right-click menu is available in 
the structure view. 
To view a document in the Structure view: 

• Select Document Structure view from the View menu. 

Document Outline Navigation 
In the Document Outline view you can generate an outline based on 
the tagged elements of your document and quickly jump from one 
section to the next.  It is created using the Resource Manager. 
To generate a document outline: 

• Select Document Outline from the View menu.  This 
automatically displays the Resource Manager frame in 
XMetaL; 

• Select the level in which to navigate from the drop-
down box in the left-hand side column; 

• Click on the Generate button; 

• Move through the document by clicking on the purple 
text in the directory list that was generated; 

• Close the document outline by clicking on the X in the 
corner of the Document Outline window. 

 It may be necessary to press the right arrow key on your keyboard to refresh the screen after the Document 
Outline is closed. 

Table of Contents Navigation 
To navigate using a table of contents in your document: 

• Place your cursor in a level in the TOC; 
• Select Table of Contents Navigation from the GO menu, 

or press CTRL+ALT+SHIFT+T. 
The cursor will be moved to the level selected.  To return to the TOC 
repeat the previous steps. 
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The Go Menu 
You can jump from one position in your document to another using the 
Go menu in the XMetaL toolbar. 

 
You can move your cursor to different locations in your document by 
selecting any of the following options: 

• To move to the previous level of your document, Click 
Up One Level, or press CTRL+UP ARROW; 

• To move to the next level of your document, click 
Down One Level, or press CTRL+DOWN ARROW; 

• To create a custom level for navigation, click Set 
Selected Level for Up/Down, or press CTRL+ALT+UP 
ARROW; 

• To move to the previous custom level of your 
document, click Up Selected Level, or press 
CTRL+ALT+UP ARROW; 

• To move to the next custom level of your document; 
click Down Selected Level, or press CTRL+ALT+UP 
ARROW; 

• To move to a bookmark, click Go To Bookmark from 
the Go toolbar, or press CTRL+ALT+SHIFT+M. 

 To create a custom bookmark for navigation, click Bookmark from the Insert toolbar, or press 
ALT+SHIFT+M. 
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The Pre-form and Bill Header 

The HOLC pre-form 
The pre-form is information preceding the form or bill head.  It 
contains information unique to HOLC and SOLC and the pre-
introduced and introduced stages.  Each element (tag) in the pre-form 
can be printed or hidden, and elements that you can enter text appear 
in the document with a text marker, like so, {elementname}.   

Element name Description Display and sample text 

author-note 

Prints a heading at top left hand corner of each printed 
page of the document. 
Hide this element (tag) for floor introduction 

{author-note} 
Sample text: the date of the 
discussion draft.  

running-header 

Prints a centered heading at the top of each printed 
page. 
Hide this element (tag) for floor introduction 

{running-header} 
Sample text: Discussion Draft. 

first-page-header 
Inserts a centered heading at the top of the first page.  
Hide this element (tag) for floor introduction 

{first-page-header} 
Sample text: Discussion Draft 

signature-line 

Line for Member to sign when the measure is dropped 
in the hopper.  
Unhide this element (tag) for floor introduction 

(Original Signature of Member) 
Text: (Original Signature of 
Member) 

legis-counsel 
Indicates which Legislative Counsel drafted the 
document 

H.L.C. 
Sample text:  H.L.C. or S.L.C. 

reintroduction-code 

This information is provided to the Parliamentarian’s 
office by the legislative counsels. 
Unhide this element (tag) for floor introduction if it is 
being used. {reintroduction-code} 

First-page-date Location where the date can be inserted and printed. {first-page-date} 

First-page-description: Location where a description can be added {first-page-description} 

Suspension-floor-action 
Suspension-instructions 

Both elements (tags) are used for measures that are 
considered under suspension of the rules.  
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The pre-form data listed below is specific to the House Office of 
Legislative Counsel and is not visible in Plain (tags-off) view.  While 
this information is viewable in the Tags-On view, drafters are 
encouraged to use the Document Information feature to view and print 
out the document information. 
Elements (tags) hidden in 
normal view Description 
Holc-filename Name and location of current file. 

Holc-attorney Name of the attorney 

Holc-last-author Name of the last person editing the document 

Holc-last-saved Date and time the current document was last saved. 

Holc-contact  

Holc-contact-phone  
Holc-creation-date Date and time the document was created. 

Holc-creator Name of the person who created the document. 

Version  
version-filename 
version-creator 
version-date 

The document could have several of these. 
Filename of the archive version. 
Creator of the archive version. 
Date that the archive version was created. 

Conversion-notes 

If the file was converted from locator codes (XyWrite) 
to XML, any conversion notes would be included in the 
pre-form. 

To view document information: 

• Select Document Information from the File menu. 
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Inserting the pre-form 
• Select Add HOLC PreForm from the LegDocMgt menu; 

 

• A dialog window is displayed allowing you to select 
whether you want to insert an attorney name; 

 

• Press Yes or No; 

• If you selected yes, a dialog window is displayed for you to 
select an attorney name; 

 

• Press ok.  A dialog window is displayed allowing you to 
select whether to change the current stage of the document: 

 
Press Yes or No; 
If you selected No, the current stage is not modified; 
If you selected Yes, a dialog window is displayed that will allow you to change the stage to one of the 
following options: 
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• Click OK; 

 
The pre-form elements are added to the beginning of your document. 
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Deleting the pre-form 
Choose Delete HOLC Pre-form from the LegDocMgt menu.  The HOLC 
pre-form is automatically deleted when the stage of the bill is changed 
from pre-introduced to another stage. 

 The data in the HOLC pre-form is proprietary to HOLC, and used only during the pre-introduction\drafting 
stage. 
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The form or bill head 
The form contains the bill head and other information that is important 
as the measure moves through the various legislative stages. 
Tags Description 

congress 

The number of the Congress, e.g., “101st Congress” or “The 
One Hundred and First Congress.”  The format depends on the 
stage of the measure. 

session 
The session, or meeting, of Congress, e.g., “1st Session”, “2d 
Session”, “3d Session”, “4th Session”, etc.  

distribution-code 

Used by the Government Printing Office to distribute paper 
copies of a measure to congressional and other governmental 
offices. Indicates the stage or type of measure, but is used to 
tell GPO to whom measures should be distributed. 
The values are as follows: I: Public Bills Introduced or 
Referred in the House, IA: Joint Resolutions Introduced or 
Referred in the House, IB: Public Bills and Joint Resolutions 
Reported in the House, II: Public Bills and Joint Resolutions 
Introduced or Reported in the Senate, IIA: Public Bills and 
Joint Resolutions Referred in the Senate, III: Simple and 
Concurrent Resolutions in the Senate, IIIA: Amendments in the 
Senate, IV: Simple and Concurrent Resolutions in the House, 
V: Private Bills Introduced in the House, VI: Private Bills 
Introduced in the Senate, VII: Private Bills Reported or 
Referred in the House, VIII: Private Bills Reported or Referred 
in the Senate, IX: Reprint Bills for House Document Room, 
and X: Reprint Bills for Senate Document Room.  

legis-num 

The “legis-num” is the legislation's official identifier e.g., 
“H.R. 1514” or “S.J. RES. 42” The first “word” indicates the 
chamber creating the legislation and the type of legislation. 
Values are: H.R. for House Bill, S. for Senate Bill, H.J. RES. 
for House Joint Resolution, S.J. RES. for Senate Joint 
Resolution, H.CON. RES. for House Concurrent Resolution, 
S.CON. RES. for Senate Concurrent Resolution, H. RES. for 
House Simple Resolution, and S. RES. Senate Simple 
Resolution.  

current-chamber 

Identifies the chamber currently having control of the 
legislation (e.g., “In the House of Representatives” or “In the 
Senate of the United States”). 

action-date 

The date or dates on which a particular floor action occurred. 
There may be two dates associated with an action, the regular 
calendar date and the legislative day. Sometimes the textual 
descriptions of these dates do not divide neatly into two parts, 
for example, the full date may be written as “February 3 
(legislative day, January 30), 1995”. Therefore, the ACTION 
DATE is just data characters, to be entered in any fashion 
necessary. 
For purposes of searching, for date comparisons and, the real 
values of the date and the Legislative Day are stored in the 
attributes for this element (tag): date and legis-day in the 
machine-readable “YYYYMMDD” format. The year is the first 
four digits, followed by the 2-digit month, followed by the 2-
digit day. For the month and day, zero fill as necessary to 
produce two digits. Used in the action element (tag). 
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Tags Description 

action-desc 

Description of the floor action taking place (i.e., introduction, 
committee referral, committee action, committee reporting, 
calendar placement).  Used in the action element (tag). 

action–instruction 

Instruction related to the action.  For example,“[Strike out all 
after the resolving clause and insert the part printed in italic]”.  
Used in the action element (tag). 

legis-type 
Container for whether the document is “A BILL” or “AN 
ACT” or “AMENDMENT.” 

official-title The official title of a measure, sometimes called the long title. 

calendar 

Legislative calendar name and number. In the House, examples 
are Consent Calendar No. 4, Union Calendar No. 3, House 
Calendar No. 12, Private Calendar No. 1, Corrections Calendar 
No. 6, and Discharge Calendar No. 1. In the Senate, examples 
are Executive Calendar No. 1 or Legislative Calendar No. 3. 

associated-doc 

Identification of other documents that have an association with 
the current document such as reports, companion bills, identical 
bills, amendments, etc. 
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Inserting Sponsors/Cosponsors and Committees 
To insert a sponsor/cosponsor or committee: 

• Select Sponsor and referrals from the Insert menu, or press 
CTRL+SHIFT+A.  

 
• Starting on the left of the dialog box, use the drop down 

boxes to select the sponsor, cosponsor(s), and 
committee(s), or type the first few letters of the name in the 
drop down box; 

• With a Member's name in one of the left text boxes, click 
on the question mark to view the room and telephone 
number; 

• Click on the arrow button or press the Enter key to move 
your selection to the box on the right. Continue down the 
form; 

• Highlight the Member name (or Committee), and click on 
the Move Up or Move Down command buttons to place them 
in a particular order; 

• To remove a Member's name (or Committee), highlight the 
name and click the Remove button; 

• When your selections are completed, click the OK button or 
press ALT+O; 

• The text (names) on the right side, if you have selected any, 
will be inserted as the legislative action in the bill form.  
The sponsor and cosponsor fields will be blank if you did 
not select any names. 
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Inserting the Bill Number 
To insert the Bill Number, delete the underscore and type in the bill 
number. 

Inserting the Action-Date 
To insert the Action-Date: 

• Place the cursor on the{action-date} marker; 

• Select Set Action Date from the right click menu or press 
CTRL+ALT+D.  A dialog window is displayed that allows 
you to select a date using a calendar: 

 
You can scroll through future months and years by using the drop down 
lists in the top right hand side of the window; 

• Press OK when you selected a date.  Two dates may be 
associated with an action, the calendar date, and the 
legislative day.  A dialog window is displayed that prompts 
you concerning legislative dates; 

 

• If you select No, only the selected date is inserted: 
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• If you select Yes, the selected date is inserted with a 
legislative date: 

 

Inserting the Official Title 
To insert the Official Title: 

• Place the cursor after the text To on the bill form; 

 

• Type the official title. 
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Drafting Legislative Language 

Legislative Styles 
As defined by Lawrence Filson in the book, The Legislative Drafter's 
Desk Reference, "'Drafting style' is the term used to describe the 
external characteristics of legislative language, and has nothing to do 
(directly) with what that language does or how the bill as a whole is 
organized." 
XMetaL supports drafting in the three main styles: OLC, Traditional, 
and USC.  You will have the flexibility to draft documents with these 
styles, "modified" styles and several quoted block styles with XMetaL.  
The following types of measures can be created in XMetaL. The 
options correspond with the drop-down boxes in the File/New dialog 
box. 

H. R. (bill) Styles 
• OLC 

This style of bill is the standard style used by the House and Senate 
legislative counsels.  In 1974, HOLC began drafting measures, 
particularly bills, using the OLC or “office” style, which is based on the 
earlier revenue style. 

• Traditional 
This style of bill is characterized by centered section headings.  When 
drafting in traditional style, the headers for sections are not displayed 
on the screen as being centered; but they are centered when the 
document is printed in PDF. 

• Appropriations 
Generally, this style of bill is generally used to draft appropriations. 

A quoted block is a series of levels that are quoted as opposed to a quoted phrase within text.  The legislative 
body of the bill will have one style, while each quoted block may have the same or a different style. 
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H. J. Res (House Joint Resolution) Styles 
• OLC 

Typically, this type of resolution is characterized by a single resolving 
clause with no run-in text. Text begins under the Resolved clause with 
an OLC-style "SECTION 1." Header. 

• Traditional (standard) 
Typically, this type of resolution is characterized by a single resolving 
clause with run-in text ("Resolved, That…"). Subsequent sections are 
in traditional style and begin with "Sec. 2." etc. Standard-form 
resolutions may include Whereas clauses. 

• Constitutional Amendment 
This type of resolution is used for purposes of amending the U.S. 
Constitution. 

H. Con. Res. (House Concurrent Resolution) Styles 
• OLC 

Typically, this type of resolution is characterized by a single resolving 
clause with no run-in text. Text begins under the Resolved clause with 
an OLC-style "SECTION 1." Header.. 

• Traditional (standard) 
Typically, this type of resolution is characterized by a single resolving 
clause with run-in text ("Resolved, That…"). Subsequent sections are 
in traditional style and begin with "Sec. 2." etc. Standard-form 
resolutions may include Whereas clauses. 

H. Res. (House Resolution) Styles 
• OLC 

Resolutions that are created using an OLC style are characterized by a 
single resolving clause and no run-in text. Text begins under the 
Resolved clause with an OLC-style "SECTION 1." header. 

• Traditional (Standard) 
Resolutions that are created using a Traditional style are characterized 
by a single resolving clause with run-in text ("Resolved, That…"). 
Subsequent sections are in traditional style and begin with "Sec. 2." etc. 
Standard-form resolutions may include whereas clauses. This is the 
default style for House resolutions in XMetaL. 

• Order of Business [or Special Rule] 
Order of Business, or Special Rule, forms are primarily used by the 
Rules Committee to draft order of business resolutions.  The 
appearance is identical to the Traditional (Standard) form resolutions 
with one exception; there are no “Whereas” clauses.  

• Concur with an Amdt.  
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Typically, this type of resolution is characterized by a single resolving 
clause with run-in text, followed by one of more undesignated full 
measure paragraphs, followed by text in any style (default if OLC 
style) that could begin at any level and with any enumerator.  In ATH 
version, line numbers begin with Resolved clause; in EH version, line 
numbers begin with the unquoted block. 

• Multiple Resolving Clause  
Typically, this type of resolution is characterized by multiple resolving 
clauses. Each main (full-measure) text paragraph begins with a 
resolved clause. This may be overcome for subsequent paragraphs to 
allow insertion of a text paragraph that is full-measure but does not 
begin with a Resolved clause. Principle use is for death (condolences) 
resolutions, but may be used for other purposes. 

• Impeachment 
Typically, this type of resolution is similar to the traditional (Standard) 
form resolutions, but with a different style in the engrossed version. 
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Section Template 
• OLC 

• Traditional 

Please see Working with Documents to learn more about using section 
templates. 

Setting Bill and Resolution Styles 
To change the style of the legislation after the document has been 
created: 

• Place the cursor somewhere in the legislative body (but 
outside of any quoted block material) and press 
ALT+SHIFT+S, or; 

• Select Set Legislative Style from the Format menu and click 
on the appropriate style name. 

Quoted-Block Styles 
• O.L.C. 

This type of bill is the standard style used by the House and Senate 
legislative counsels.  In 1974, HOLC began drafting measures, 
particularly bills, using the OLC style, which is based on the earlier 
revenue style.  

• Traditional 
Typically, this type of bill is characterized by centered section 
headings.  (While drafting in traditional style, the headers for sections 
will not appear centered on the screen; although the headers will print 
centered on the PDF.) 

• U.S.C. 
Similar in nature to O.L.C. style, but Sections are preceded by the 
Section symbol §. 

• Other 

• Archaic 
This style is characterized by centered subsection headers.  It is used 
when amending the Social Security Act. 

• Nuclear 
This style is characterized by enumerators that do not have parenthesis.  
It is used when amending the Atomic Energy Act of 1954 (42 U.S.C. 
2014).  
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 The Railroad Retirement Act of 1974 can be drafted in traditional quoted block style and Chapter 119 of 
Title 18 of the U.S. Code can be drafted in USC quoted block style.  The enumerators follow a different pattern than 
the standard OLC, USC and Traditional styles.  Users will have to manually type the correct enumerator in the first 
level of a series or turn off  the auto-rededesignate feature in the User preferences and manually renumber the 
enumerators.  Excerpts of the Railroad Retirement Act of 1974 and Chapter 119 of Title 18 can be found in the 
appendices of this document. 

Setting Quoted Block Styles 
To set a quoted block style: 

• Click Set Legislative Style from the Format menu, or press 
ALT+SHIFT+S; 

• Select one of the following styles:. 

While drafting in traditional style, the headers for sections will not appear centered on the screen; although 
the headers will print centered on the PDF.  At this time, there is no available technical solution to display section 
headers centered on the screen.   

To assist the drafter, gray generated text indicating the style of the quoted block appears at the beginning of the 
quoted block.   
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Section Types 
The following types of sections are allowed within bills and 
resolutions: 

Section Types  
• Resolved 

Typically, this type of section has the word “Resolved” at the 
beginning of it. It is used in resolutions. 

• Undesignated 
Typically, this type of section is seen in resolutions or traditional style 
bills. Undesignated sections do not have a designator and do not need a 
Section heading.  In resolutions, the undesignated section is typically 
the first section.  

• Subsequent Section (Sec.) 
This type of section has the word “Sec.” at the beginning of it. 

• Section One (Section) 
This type of section has the word “Section” at the beginning of it.  

Changing Section Types 
To change a section type: 

• Put your cursor in the section you want to modify; 
• Select Change the Section Type from the Format menu, or 

press CTRL+SHIFT+4; 
• Select correct type from the dialog box.  (While a particular 

section style may be available, drafting styles may dictate 
whether a particular section type is used or not.) 

Changing Section 1 to a Traditional Section 
The bill form, whether drafting in traditional style or OLC, always 
starts with Section 1. To draft a traditional bill with only one section, it 
is typical not to have a Section designator and the text to start 
immediately after the enacting clause with the word “That”.   
Example:  H.R. 3126 from the 108th Congress. 
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XMetaL (left-hand side) GPO PDF (right-hand side) 
 
To change Section 1 to a Traditional Section “, That…” 

• Place cursor in the existing header of Section One, and 
select Traditional: Section “That” from the Format menu, or 
press F5.   
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Working with Text 
Entering text 
For ease and efficiency, you should type in sentence-style casing 
throughout the legislative document, particularly in the headers. The 
casing of the headers in the final typeset, printed document will be 
printed correctly based on the level name (section, subsection, 
paragraph, etc and the legislative style of the document (or quoted 
block).  
The advantage of typing in sentence style is clear: 

• Little need to think about the correct casing for each level.  

• When levels are moved (promoted or demoted) during 
drafting, the casing will not need to be "fixed".  

• Tables of contents can be automatically generated without 
adjusting the casing of the table of contents entries. 

For those authors who are most familiar with drafting in XyWrite, it may be easier to think that all headers 
in XML should be typed like Table of Contents entries are typed in XyWrite. (Table of Contents entries are typed in 
sentence-style in XyWrite.) 

Setting Text Casing 
The casing of text can be changed to uppercase, lowercase, sentence, 
and title style casing.  To change text casing: 

• Select desired text, then select Change Case (capitalization) 
from the Format menu, or press SHIFT+F3.  

• Continue selecting Change Case (capitalization) from the 
Format menu, or press SHIFT+F3 until the desired casing 
style is set. 

The majority of your work should be typed in sentence-style.  It is most likely that changing the casing of text 
will be used on copied or inserted material. 
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Exception Words 
The exception words are: and, an, as, at, a, but, by, for, in, not, of, on, 
or, the, to. 
The XML to PDF functions in XMetaL will print exception words in 
lower case in the headers, even when the headers are set in caps and 
small caps or caps in lower case. 
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Working with Resolutions 
To access resolution functions: 

• Select Resolutions Menu from the Insert menu and chose one 
of the following functions. 

Inserting Committee Appointment paragraph 
When drafting Committee Appointment Paragraph, use this command 
to insert the proper type of paragraph: 

• Select Resolutions…Committee Appointment Paragraph from 
the Insert menu, or press ALT+SHIFT+2. 

Inserting Whereas Clause for Resolutions 
To insert a new Whereas clause in the Resolution: 

• Select Resolutions…Whereas Clause in Resolution from the 
Insert menu, or press CTRL+SHIFT+W; 

• The Whereas clause will be inserted as the first one in the 
resolution. 

Inserting First Resolving clause in Resolution 
To insert a new first Resolving clause in the Resolution,: 

• Select Resolutions…Resolving paragraph clause from the 
Insert menu; 

• The Resolving paragraph will be inserted as the first one in 
the resolution. 
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Creating Levels 
Level Elements 
A level is a unit of the legislative body.  Section, Subsection, 
Paragraph, Subparagraph, Clause, Subclause, Item, and Subitem are 
levels.  In bills, a level contains an enumerator, followed by an 
optional header and optional text. 
Levels can be nested within each other to reflect the legislative 
structure and are stored in a container.  A container consists of one 
level and all of its sublevels. 
In the example below each individual line is considered a level, for a 
total of seven levels.  There are three main containers -- a subsection 
container and two paragraph containers: 

(B) MUSICIANS OF THE 20TH CENTURY SUBSECTION 

     (1) JAZZ MUSICIANS PARAGRAPH 

          (A) MILES DAVIS 
          (B) JOHN COLTRANE SUBPARAGRAPHS 

     (2) BLUES MUSICIANS PARAGRAPH 

          (A) JOE TURNER 
          (B) B.B. KING SUBPARAGRAPHS 

You may use one of two methods to create levels.  The Relative Method 
views a level in a relational or hierarchical manner using the terms 
"same level", "next level down" and "next level up". The Direct Method 
creates levels directly based on their name (Section, Subsection, 
Paragraph…). Both methods will produce the same results. 

It is important to note which level the cursor is in when working in XMetaL, particularly when creating, 
moving, joining, deleting and copying parts of the document. 
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The Relative Method 
To use the relative method: 

• Place the cursor at the end of the text in a level; 

• Press ENTER for a repeating level, or; 

• Press CTRL+ENTER for the next level down, or; 

• Press CTRL+SHIFT+ENTER for the next level up, or; 

• Select an option from Section levels from the Insert menu; 

• Place the cursor on the {header} marker. Type the desired 
text. Place the cursor on the {text} marker. Type the 
desired text.   See "Working with Levels" to learn more 
about inserting headers and text. 

If the cursor is not at the end of the line when you are creating a new level, the text following the cursor will 
be “pushed” into the newly created level.  If the cursor is inside the enoumerator and you press Enter, the new 
level will be created before the existing level.  If the cursor is inside the enumerator and you press CTRL+ENTER, 
the new child level crated will also be inline.  I.E.  (a)(1) Sample text. 

• Press the End key so the cursor is at the end of the line.  
Continue using the ENTER, CTRL+ENTER, and 
CTRL+SHIFT+ENTER to create additional levels. 

To create levels above a section, press ALT+B.  To create a section below a big level, press CTRL+0, or 
CTRL+ENTER.  To convert Section text to a subsection, place cursor in text, and select Section Text to 
Subsection from the Format menu. 

The Direct Method 
To create a specific level, follow the above directions using the 
keystrokes below, or select an option from Section levels from the 
Insert menu. 

• CTRL+0……………Section 

• CTRL+1……………Subsection 

• CTRL+2……………Paragraph  

• CTRL+3……………Subparagraph 

• CTRL+4……………Clause   

• CTRL+5……………Subclause  

• CTRL+6……………Item   

• CTRL+7……………Subitem 
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Working with Levels 
Header and Text Elements 
Each level may contain a header or text, or both. The bill language 
inside the header or text should be typed in sentence casing. To aid in 
drafting, {header} and {text} markers indicate the location of the  
<header> and  <text> elements in each level. 

• With the cursor in the level, select Header Element from the 
Format menu, or press CTRL+H; 

• With the cursor in the level, select Text Element from the 
Format menu, or press CTRL+T; 

• If you repeatedly click Header Element or Text Element from 
the format menu, or if you repeatedly press CTRL+H and 
CTRL+T, XMetaL will cycle through three options: 
o Creates the element if it does not exist; 
o Moves the cursor to that element if it exists, and; 
o Deletes the contents of the element and the element 

itself. 

Copying Text between the Header and the Text 
To copy text from the header to text or the other way: 

• Select desired text. 

• Press CTRL+SHIFT+H, or select Copy (Toggle) Text to Header 
or Text from the Format menu. 

Moving Text from the Text to the Header 
To move text from the Text to the Header: 

• Select desired text. 

• Press CTRL+SHIFT+H, or select Copy (Toggle) Text to Header 
or Text from the Format menu. 
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Inserting Big Levels 
To insert a big level: 

• Place cursor in the level above where you want the Title (or 
other big level) to be located and; 

• Select Big Levels from the Insert menu, or press ALT+B; or 

• Use one of the following keystrokes: 
ALT+1……………Title 

ALT+2……………Subtitle 

ALT+3……………Part 

ALT+4……………Subpart 

ALT+5……………Chapter 

ALT+6……………Subchapter 

ALT+7……………Division 

ALT+8……………Subdivision 

Inserting the First Section within the Title 
To create the first Section within the Title (or Division): 

• Place the cursor at the end of the header of the Title (or 
Division): 

• Press CTRL+0. 

Joining Levels 
To join or combine levels: 

• Place the cursor in the top level that you would like to join; 

• Select Join Levels from the Format menu, or press ALT+J. 
Note that the cursor is now placed in the level you joined.  In the 
following example when paragraph A and B are joined, the cursor 
appears in the  “(A) Miles Davis" level. 

(B) MUSICIANS OF THE 20TH 
CENTURY 

SUBSECTION 

     (3) JAZZ MUSICIANS      (3) JAZZ MUSICIANS 
         (A) MILES DAVIS 
         (B) JOHN COLTRANE 

                         (A) MILES DAVIS JOHN COLTRANE 
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Starting a new bill with a Title 
• Select Title:  Start bill with a Title from the Format menu; 

If your document only has one section, it is removed when the Title is 
inserted.  If your document has more than one section, the Title is 
inserted before the first section and the sections are not altered. 

Starting a new bill with a Title is developed for bills only.  You cannot perform this function in resolutions or 
amendments. 
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Promoting and Demoting Levels 
The promote/demote commands allow a Paragraph to be promoted to a 
Subsection or demoted to a Subparagraph, a Subparagraph promoted 
to a Paragraph or demoted to a clause, and so forth.  
The promote/demote commands affect the sublevels within the level 
you are promoting or demoting. For example, if you promote a 
Paragraph that contains a Subparagraph, the Paragraph becomes a 
Subsection and the Subparagraph becomes a Paragraph. The 
enumerators are re-designated in the process. 

An important point to remember when drafting in XMetaL is that material needs to be surrounded by tags 
with names that reflect what the material is.  I.E.  Sections need to be surrounded by section tags, subsections by 
subsection tags and Headers needs to be in header tags, and so forth. 

Copying or Moving text between the Header and the 
Text 
To copy text from the header to text or the other way: 

• Select desired text; 

• Select Copy (Toggle) Text to Header or Text from the Format 
menu, or press CTRL+SHIFT+H. 

Redesignating Levels 
Enumerators are automatically renumbered by default.  You may, 
however, renumber or redesignate them if needed. 
To change an enumerator: 

• Change the enumerator by deleting its current number or 
letter and typing a new number or letter in its place;  

• Use one of the following methods to renumber/redesignate:  

• Select Renumber This Level from the Format menu, or; 

• Press CTRL+R. 
Renumber does handle enumerator that are unique, like “Section 
199a.”, and nuclear style subsections, like “b.”. 
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Sorting Levels 
If you are familiar with the sort feature in XyWrite for HOLC, then 
sorting in XMetaL will be easy for you to use. 
To sort levels: 

• Type the desired enumerator in the appropriate levels; 

• Select Sort Levels (by enum) from the Format menu. 

Promoting/Demoting Big Levels:  
You can promote and demote all levels, including big levels,  Due to 
the variation in the order of Big Levels in public law, it may be 
necessary to specify which level is desired.  For example, a Part could 
be promoted to a Title or a Chapter.   A Subtitle could be demoted to a 
Part or Chapter.  In these instances, a dialog box will appear with valid 
choices. 
To promote or demote levels: 

• Place your cursor in the level that you want, or highlight 
multiple levels, to promote or demote; 

• To promote your selection, click Promote Level from the 
Format menu, or press ALT+SHIFT+P; 

• To demote your selection, click Demote Level from the 
Format menu, or press ALT+SHIFT+D 

The following example illustrates changes if your cursor is placed in 
the paragraph  

 

While Sections may be promoted to big levels, big levels cannot be demoted to Section or below levels. 
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Swapping or Moving Levels Up and Down 
To move a level up: 

• Place the cursor in the level that you would like to move; 

• Use one of the following methods to move the level up: 

• Press CTRL+\ to move the level up, or; 

• Select Move Level/Container Up from the Format menu, or; 

• Use the icon on the toolbar. 
To move a level down: 

• Place the cursor in the level that you would like to move; 

• Use one of the following methods to move a level down: 

• Press CTRL+SHIFT+\, or; 

• Select Move Level/Container Down from the Format menu, or; 

• Use the icon on the toolbar. 

Creating Flush-Left or Continuation Text 
Flush left, or continuation, text can be inserted when you need to add 
text to a previous level in a document.  This block is added at the end 
of the section and aligns with the level that it is continuing.  Listed 
below is an example: 

 
One continuation text block can be created for each level within a 
section.  Each block is inserted based on where your cursor is placed 
and the document structure. 
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To create a continuation text block: 
• Place your cursor anywhere after the level you want to 

create a continuation text block for; 

• Select Flush-Left Text from the Insert menu, or press 
CTRL+SHIFT+F; 
The continuation text block is inserted at the end of the section, and 
aligned with the associated level, as displayed in the example below: 

To modify a continuation text block: 
• Place your cursor inside the continuation text block and 

press CTRL+SHIFT+F; 
The associated level for the text block is changed to the preceding 
level.  You may repeat this action repeatedly to move it all the way to 
the beginning of the section if needed. 

The text [FLUSH-LEFT TEXT: paragraph] indicates which level the continuation text is attached.  You may 
delete continuation text by placing your cursor inside the comment and selecting delete level.  A dialog window is 
displayed that will allow you to only delete continuation text, not the level. 
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Moving a level inline 
You can move a level inline with the preceding level as shown in the 
example below: 
To move a level inline with another level: 

• Place cursor in the level you want to move.   

 
In the example above the cursor is positioned in subsection 1; 

• Select Toggle text or level (inline/not inline) from the Format 
menu, click on the Move Level Inline icon on the toolbar; or 
press F11.   

 
As shown above, the subsection is moved inline with the section level. 

Adjusting a level’s indent value 
To override a single level's indent value: 

• Place the cursor on the level you want to change; 

• Use one of the following methods to adjust the level’s 
indent valueto select the appropriate level of indentation 
from the dialog box: 

• Select Adjust Indent from the Format menu; 

• Press ALT+SHIFT+O, or; 

• Click on the Indent Override icon on the toolbar. 
To undo a level's indent override: 

• Place the cursor on the level and repeat the steps above 
selecting "Remove" from the dialog box.  
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In the example below the text was returned to its original indentation. 

 

Toggling between Section Text and Subsection (a) 
There are times when an author will need to change the Section Text 
to a Subsection (a) and add a Subsection (b).  (or the author needs to 
convert Subsection (a) to Section Text.) 

 

Converting Section Text to Subsection (a): 
To convert Section Text to Subsection (a): 

• Place the cursor anywhere in the Section Text; 

• Select Section Text to Subsection (and back) from the Format 
menu, or; 

• Click on the green icon on the toolbar, or; 

• Press F12. 

It is important NOT to delete the enumerator in Subsection (a) and believe that you have the correct 
structure. You must convert Subsection (a) to Section Text using the tools available.  Deleting the enumerator in 
Subsection (a) will cause problems later in the drafting (pre-introduced stage) process and for other offices who 
handled the electronic file (introduced stages and beyond). 
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Converting Section Text to Subsection (a) and add 
Section (b): 
To convert Section Text to Subsection (a) and add Section (b): 

• Place your cursor in the Section Text; 

• Press CTRL+1.  The Section text will be converted to 
Subsection (a) and a Subsection (b) will be added. 

CTRL+1 works differently depending on where your cursor is.  If it is at the end of the line, the text will 
remain in the newly created Subsection (a).  If this cursor is at the beginning of the line, the text will be pushed into 
the newly created Subsection (b).  If the cursor is left in the middle of the text, the text will be split between 
subsection (a) and (b). 
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Delete, Cut, Copy and Paste 
Using the Cut, Copy, Delete and Paste functions you can easily select 
and move parts of your document, or insert material from other 
documents created in Word or WordPerfect.  These functions have 
been customized in XMetaL to recognize the type of material that is 
copied to the clipboard so that it can be handled correctly when you 
paste it to ensure that your document remains valid. 
The features listed below have been customized to work in normal 
view only.  If you try to use these commands in the tags on or text 
view you will get very limited results and possibly make the document 
invalid. 

Copying and Cutting Text 
The cut and copy commands behave similarly to windows and use the 
same shortcuts, but they have been customized to recognize the 
corresponding tags that are used in XML documents to ensure that you 
never move or cut just part of the structure.  If you select all of the 
words in an element, such as a header, it will also place the beginning 
and ending tags on the clipboard.  Similarly, if you select all of the 
elements in a level you can copy the entire level.  If you select all of 
the levels in a section, it also copies the container. 
To copy text from an XML, Word, or WordPerfect document: 

• Select the text you want to copy to the clipboard; 

• Select Copy from the Edit menu or press CTRL+C. 
To cut text from an XML, Word, or WordPerfect document: 

• Select the text you want to move to the clipboard; 

• Select Cut from the Edit menu, or press CTRL+X; 

• XMetaL will renumber your document based on the 
AutoRedesignate setting in your user preference settings. 

Clipboard Contents 
The clipboard temporarily stores a copy of text that was "copied" or 
“cut" and stores this information so that you can paste it into a 
document as often as you need to.  The clipboard is automatically 
emptied when you copy or cut new material, or if you close the 
application. 
To view the contents of your clipboard: 

• Select Clipboard Contents from the Edit menu. 
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Pasting Text into an XML Document 
The Paste command is similar to Windows and uses the same shortcut, 
but it has been customized to evaluate the type of material that is 
copied to the clipboard before pasting into an XML document.  If your 
clipboard contains levels, and the location you are trying to paste them 
into will make structure invalid, it will promote or demote the levels to 
ensure that your document remains valid. 
To paste text in an XML document: 

• Position the cursor where you want to insert the text; 

• Press CTRL+V, or select Paste from the Edit menu. 
The clipboard material will be pasted into your document based on the 
material you are pasting and where your cursor is placed.  The paste 
conditions are listed below: 

• If the material on your clipboard is in a level or container, 
the clipboard material is pasted below the current level. 

• If the levels you are pasting cannot be inserted, a dialog 
window is displayed that allows you to select a valid level 
that the material can be pasted into; 
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• If the material on your clipboard is text, the clipboard 
material is pasted into the current element; 

• If the text on your clipboard contains non-structured tags, 
such as italic, they won’t display if you view the clipboard 
contents, but they will be pasted. 

 

• If your user preference settings for AutoRedesignate are set 
to Y each time you cut, copy, or paste levels or containers 
the document will be automatically renumbered.  If 
AutoRedesignate is set to N you can select Renumber this 
level from the Format menu or toolbar, or press CTRL+R. 

Copying Text and Levels between XML documents 
To copy and cut text and levels between two XMetaL documents: 

• Open both documents; 

• Switch to Workbook Mode by selecting Other Views and 
Tools…Workbook Mode from the View menu.  This will 
allow you to move between the two open documents using 
the tabs in the bottom left hand corner, 

• Select Cut (or Copy) from the Edit menu, or press CTRL+X 
(or CTRL+C). 

• Switch to the second document using the tabs on the 
bottom of the window. Position the cursor where you want 
to insert the level,  

• Select Paste from the Edit menu, or press CTRL+V. 



Congressional Help Drafting Legislative Language  •  75 

Pasting Text into a Word or WordPerfect Document 
You may copy text from your XMetaL document and paste it into 
another type of document using the cut, copy, and paste functions.  
When the material is pasted into the new document it will not contain 
the XML tags, but will keep the level numbers and line spacing for 
levels, as well as column spacing in tables. 

Deleting Text 
To delete text: 

• With your mouse, select the text you want to delete; 

• Press the DELETE key, or; 

• Place the cursor behind the text you want to delete; 

• Press the BACKSPACE key. 

Deleting Levels 
To delete a level and its contents: 

• Place your cursor in the level to be deleted; 

• Press CTRL+SHIFT+X, or select Delete Level from the Edit 
menu, or; 

• Right-click with your mouse and choose Delete Level/Item 
from the pop-up menu. 

The following elements are not automatically deleted within a level.  
They are: 

• In-line comments; 

• Legis-comments; 

• Header in text; 

• Continuation text; 

• Enum in header. 
If the level you are deleting contains any of these elements, a dialog 
window is displayed that allows you to chose whether you want these 
elements deleted with the level. 
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Working with Quoted Material 
You may create quoted material using quoted phrases, or by creating 
quoted blocks.  You may also convert existing text in your document 
to quoted, or convert quoted blocks to text.  Listed below are examples 
of how quoted material appears in an XML document: 

 

As you can see from these examples, you identify quoted phrases by 
inserting the quote marks around the text.  If you use a quoted block, 
the quote marks are inserted for you and the quoted material is 
highlighted in a different color when it is viewed in XMetaL. 

Inserting Quoted Phrases and Inline Quotes 
When quoting material, always use the inline quote function.  Do not 
insert quote characters from the special characters toolbar. 

• Press SHIFT+’, and then type the desired bill language in the 
"{quote}" marker, or: 

• Select the text you want quoted and press SHIFT+’. 
Always use the SHIFT+’ inline quote function. If you find that you need 
to cut, copy or paste text inside/outside a quoted block, the quotations 
will be changed to the appropriate single or double quotes 
programmatically. 

If you place your cursor in an existing text marker and press SHIFT+" (quote), you will not get a quote 
marker; you will get quote marks around the text marker and may proceed as if it were a quote marker. 
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Inserting Quoted Blocks 
A quoted block is a series of levels that are quoted as opposed to a 
quoted phrase within text. 
To set text as Quoted Block: 

• Place cursor in the level before the anticipated location of 
the quoted material; 

• Select Quoted-Block from the Insert menu, or press ALT+Q.  
The following dialog window will appear; 

 

• Select the style of the quoted block using the drop down 
menu; 

• Select the big level, or section, using the drop down menus; 

• Click the Add button; 

• Select OK. 
After the quoted-block has been created, you can use the direct or 
relative method to create new levels within the quoted block.  Quoted 
block text will appear blue in color.  The words [END OF QUOTED 
BLOCK] will appear in gray before the period at the end of the last 
double quote.  
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Editing the End of Quoted Block 
You can insert additional text that will be printed outside of the quotes 
by entering text at the period, as shown below: 

 

To create a new "non-quoted block" level after the quoted-block: 
• Place the cursor directly after the punctuation in the [END 

OF QUOTED BLOCK]; 
• Use the Relative or Direct method to create additional 

levels. 

You can use the Insert Quoted Text interface to create tables, a Table of Contents, or to begin a quoted block 
inline by selecting Table of Content item, or Beginning Inline from the Insert menu. 

Converting Text to a Quoted Text Block 
To convert a level(s) to a quoted text block: 

• Select or highlight (with your mouse) the levels that should 
be quoted, as shown below; 

• Select Convert to Quoted Text Block from the Insert Menu, or 
press ALT+9; 

The tags will be inserted to mark your text as a quoted block, and the 
quoted block style will be applied from your user preferences, as shown 
above. 

You must select levels carefully when converting text to quoted blocks.  If you receive an error message that 
the entire level is not selected, but it looks like all of the text is marked in the display, click Select Element from 
the Edit menu, or press CTRL+SHIFT+S. 
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Converting Quoted Block to Text 
You may convert quoted block material to text using the following 
method: 

• Place your cursor inside the quoted block you want to 
convert; 

 

• Select Convert Quoted Block to Text from the Insert Menu, or 
press ALT+SHIFT+9. 
The tags will be removed and the converted material will be inserted as 
a level in the next valid location in the document structure, as shown 
below: 

 

Converted material will not be automatically renumbered.  Please see renumbering for more information. 
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Table of Contents 
There are several types of Tables of Contents (TOC) that can be 
automatically generated in XMetaL.  TOCs can be created for the 
entire body of the document (with or without quoted blocks), for a 
portion of the document such as a Title, Chapter or Division, and for 
clerical amendments for quoted block material. 

Creating a Table of Contents 
To insert a table of contents for the entire body of your document: 

• Place the cursor before the desired location of the table of 
contents; 

• Select Create/Insert Table of contents or Entry from the Insert 
menu, or press CTRL+F7.   

 
A dialog window appears that allows you to insert a generated table of 
contents or one that you can manually type in; 

• If you select Manually typed, you must select the 
corresponding level for the level that is being used for the 
TOC.  For instance, if you are creating a TOC for a section 
header, select section.  If you are creating a TOC for a big 
level, select the appropriate Title, Subtitle, and so forth. 
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A single table of contents entry is inserted where you may enter text. 

 
You can create additional entries to this table by pressing Enter after 
you have typed in the text for this entry; 

It is recommended that you generate tables of contents whenever possible.  Generated tables of contents 
allow you to change the Section headers throughout the measure and dynamically update the TOC by regenerating 
it instead of manually retyping them. 

• If you select Generated, the macro will ask you if you want 
to include quoted block matter; 

 
If you select Yes, all quoted blocks that contain sections (or big levels) 
will be included in your table of contents. The section (and big levels) 
from the quoted blocks will be quoted in the Table of Contents.  If you 
select No, only the non-quoted sections (and any big levels) will be 
included in the Table of Contents. 

• A dialog window appears asking you if you want to insert 
the table of contents after the current cursor location. 

 
If you select Yes, the table of contents is inserted after the cursor.  If 
you select No, you can move the cursor to the desired location and 
press CTRL+V to insert the Table of Contents. 

This feature can be used when you want to generate a table of contents for a quoted block and insert the 
TOC into a quoted clerical amendment.  See the section “Creating Tables of Contents for Quoted Matter” later in 
this document for more detailed information. 
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The table of contents will be created for the entire document and 
inserted after the current cursor location.  For this example, the table of 
contents was created for the entire document without the quoted block 
portions: 

 
For this example, the table of contents was created for the entire 
document including the quoted block portions.  

 



Congressional Help Drafting Legislative Language  •  83 

Generating a TOC with Empty Enumerators 
During TOC generation, a dialog window will be displayed to notify 
you that an empty enumerator has been detected in your structure.   

• A dialog window will display for each empty enumerator; 

 

• Click OK on each widow to generate your table of contents: 

 

• Open the Resource Manager and select empty-enums; 

  

• Click the Generate button to see a list of empty 
enumerators; 

• Click on each item in the list to insert a marker and then 
enter the appropriate number; 

• When you have finished, regenerate your table of contents. 
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Creating a Table of Contents for a Big Level 
To insert a Table of Contents for a Title: 

• Place the cursor at the end of the big level and select 
Create/Insert Table of contents or Entry from the Insert menu, 
or press CTRL+F7; 

• Click the radio button for the big level that contains the 
sections you want to generate the table for; 

 
• Click OK; 

 
If you select Yes, the quoted block matter is that big level only will be 
included in the Table of Contents.  If you select No, only the non-
quoted sections (and any big levels) will be included; 

• A dialog window appears asking you if you want to insert 
the table of contents after the current cursor location. 

 
• Select Yes; 
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Creating a Table of Contents for Quoted Matter 
You can generate a table of contents and insert it into a different 
location of your document. This is particularly useful when creating a 
table of contents for a quoted block and then inserting the TOC in a 
clerical amendment.   
To insert a Table of Contents in Quoted Matter: 

• Place the cursor anywhere inside of a quoted block. 

 

• Select Create/Insert Table of contents or Entry from the Insert 
menu, or press CTRL+F7.  A dialog window appears that 
allows you to insert a generated table of contents or one 
that you manually enter; 

 

• Select Generated.  A dialog window appears asking you if 
you want to insert the table of contents after the current 
cursor location; 

 

• Select No.  A dialog is displayed instructing you to place 
your cursor where you want the table to be inserted; 

 

• Press OK, and move the cursor to the location where you 
want to insert your table and press CTRL+V; 
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Because the TOC was generated from a Quoted Block, there is no need 
to create the QB first.  Move the cursor to the end of the level.  In this 
example, it would be at the end of subsection (b); 

• Press CTRL+V.  A dialog window appears asking you if you 
want to place the Table of contents after the quoted block; 

 

• If you select Yes, a new quoted block will be created and 
the table of contents inserted, as shown in the example 
below: 

 

• If you select No, the Table of Contents will be inserted. 

 

The example above is listed for illustration purposes only.  This example would be bad drafting as the Table 
of Contents should be inside of quotes. 
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Manually Creating a Table of Contents Entry that is 
Quoted 
To insert a quoted TOC entry: 

• Place the cursor in the level before the anticipated location 
of the quoted material; 

• Select Create/Insert table of contents or entry from the Insert 
menu or toolbar, or press ALT+Q.  A dialog window is 
displayed; 

 
• Check the Table of Contents Item.  The level displayed 

when you insert a table of contents refers to the alignment 
ONLY, a new level will not be inserted using this screen.  
You can adjust the alignment inside the quoted block by 
selecting a different level in the Section & Below menu and 
then clicking the Add button; 

• Click OK; 

 
A quoted block is inserted in the document and a single table of 
contents entry is inserted. 
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Converting a Table of Contents into a Quoted Block 
To convert a table of contents into a quoted block: 

• Select the Table of Contents and the level above it; 

• Select Convert Text to a Quoted Block from the Insert menu 
or toolbar, or press ALT+9. 

 
The selected material is converted to a quoted block. 

Updating a Table of Contents 
You can update the table of contents after changes have been made in 
the body of the text by regenerating it. 

• Place your cursor in the Table of Contents you want to 
update; 

• Select Regenerate table of contents (current or all) from the 
Tools menu, or press CTRL+SHIFT+F7. 

If a table of contents in your document contains TOC entries for quoted material, only those quoted blocks 
that contain section and big levels will be included in the table of contents. All other quoted blocks will be skipped 
during creation and regeneration, as there is no material to be included. 
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Additional Drafting Tools  
Inserting a Short Title Entity 
The short title of any legislation may be formatted as a short title 
entity.  As an entity, the short title can be inserted throughout the 
document and changed in a single step to update all of the occurrences 
in the document. 
To create the short title: 

• Place your cursor where you want the short title inserted; 
• Select Short Titles from the Insert menu, or press 

CTRL+ALT+Q; 
• Type the short title in the text fields; 
• Click the Insert radio button; 
• Click OK. The short title is inserted at the cursor location. 

You may insert up to 12 short titles for each document by repeating 
these steps.  You may also insert existing titles anywhere in the 
document by repeating these steps and clicking insert on an existing 
entry. 

Changing a Short Title Entity 
To change the short title: 

• Select Short Titles from the Insert menu, or press 
CTRL+ALT+Q; 

• The short title dialog window is displayed that lists all short 
title entities in your document.  Modify the entity text you 
wish to change; 

• Click OK and all occurrences of that short title will be 
changed. 

Deleting a Short Title Entity 
To delete a short title entity: 

• Select Short Titles from the Insert menu, or press 
CTRL+ALT+Q; 

• Delete all the text of the short title entry you want to 
remove from your document; 

• Click OK and all occurrences of that short title will be 
removed. 

When you delete the text in the dialog window and press OK, the short title element tags are removed along 
with the text everywhere it appears in the document. 
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Inserting a Short Title Entity with a Section 1 header 
• Place your cursor where you want the short title section 

inserted; 

• Press ~ (tilde) + Q; 

• A new section is inserted, and section text is generated that 
states “This Act may be cited as the “__________-Act of 
2004”; 

• The Short Title dialog window is displayed with the default 
short title entity so that you can modify the entry with your 
short title; 

• Click the Insert radio button; 

• Click OK.  The short title modifications are updated in the 
document. 

Undoing Actions 
You can undo\redo your actions from the time that you last saved the 
document.  As long as you have not saved the documents, the number 
of times you many undo\redo is unlimited. 
To undo the last action performed: 

• Select Undo from the Edit menu, click on the UNDO button 
on the toolbar, or press CTRL+Z. 

To redo an action: 

• Select Redo from the Edit menu, click on the Redo button 
on the toolbar, or press CTRL+Y. 

Formatting References 
To format references: 

• Type your reference without the parentheses; 
5b3AivII 

• Leave the cursor immediate after the last character and 
press ALT+0 (zero), or select Parenthesize current reference 
from the format menu; 

• Your text is formatted automatically. 
5(b)(3)(A)(iv)(II) 
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Hide/Unhide 
Particular text of some legislation will remain in the XML document, 
but will be hidden, so that it does not print.  This text appears in lime 
green. 
To hide or unhide an element: 

• Place the cursor on the lime green text; 

• Select Hide/Unhide Element from the Format menu, or press 
CTRL+ALT+H. 

Comments 
Comments are hidden, or printed, based on your selections. 

Printed comments 
To create a printed comment: 

• Place cursor in desired location for a printed comment; 

• Select Comments/Notes…Printed Comment from the Insert 
menu, or press CTRL+SHIFT+N; 

• Type your comments in the brackets. 

Hidden comments 
To create a hidden comment: 

• Place cursor in desired location for a comment; 

• Select Comments/Notes…Hidden Comment from the Insert 
menu, or press ALT+SHIFT+N; 

• Type your comments in the brackets.  Hidden comments 
will appear in green on the screen. 
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Inline comments 
An inline comment will appear when printed. 
To create an inline comment: 

• Place cursor in desired location for a comment; 

• Select Comments/Notes…Inline Comment from the Insert 
menu, or press CTRL+ [; 

• Type your comments in the brackets. 
To delete comments you must delete the level the comment resides in: 

• Place your cursor in the comment,  

• Select Delete Level from the Edit menu, or press 
CTRL+SHIFT+X. 

You may also delete an inline comment by placing your cursor inside the comment and selecting delete level.  
A dialog window is displayed that will allow you to only delete the comment, not the level. 

Untagging inline comments 
To untag inline comments (or remove the bold brackets), use the 
Untag function: 

• Place your cursor in the comment; 

• select Un-tag the item from the Edit menu, right-click with 
your mouse and select Untag, or press the F10 key. 

Finding and Replacing Text 
There are two methods to use replacement text.  This feature is similar 
to the XyWrite's "Save-Gets" feature used by HOLC. 

Replacement Text -- Method One: 
• Select Text Menu (tilde menu) from the Insert menu, or press 

ALT+~; 

• Enter the letter (or click the letter with your mouse) next to 
the item to be inserted. 
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Replacement Text -- Method Two: 
If you have the items in the Text Menu memorized: 

• Press the ~ (tilde) key; 

• Enter the letter next to the item to be inserted. 

 If material is assigned to a capital letter, press the keys in the following order: ~ (tilde) key and then, the 
shift key and the letter together. 

To change the items in the text menu: 
• Open the Text Menu by selecting the Text Menu (tilde 

menu) from the Insert menu, or press ALT+~; 

• With the mouse, click on the text, not the letter.  A dialog 
window will appear; 

• Type the display text.  Display text is text that appears on 
the text menu. This is usually an abbreviation of the text 
that will be inserted; 

• Type the desired text in the in the area marked value. 

You may paste text into the tilde menu by right clicking in the Display Name or Value area of the text menu 
window and selecting Paste, or by placing your cursor in the appropriate area and pressing CTRL+V. 

Finding and Replacing Text 
Search and replace operations in XMetaL are similar to word 
processing applications with the following differences: 

• - Text searches will not find a match if part of the text is 
found in a separate element.  For example, if you are 
searching for 'World Wide Web' in the <header> element 
and the word 'Web' is in the <text> element, the text will 
not be matched. 

• - Choosing the Undo command after a 'replace all' undoes 
all of the replacements. 

To find and replace text: 

• Select Find and Replace from the Edit menu, or press 
CTRL+F; 

• Type the text you want to find in the Find box; 

• Type the replacement text in the Replace box; 

• Click on the Find, Replace, Replace all or Replace Find 
button, as appropriate; 
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To delete all occurrences of text: 

• Select Find and Replace from the Edit menu, or press 
CTRL+F; 

• Type the text in the Find box and leave the Replace box 
empty; 

• Click on the Replace All button. 

The Enum-in-Header tag 
The enum-in-header tag is used when you need to insert an enumerator 
in a header that needs to print in a different case than the header it is 
in.  For example, the letter b in the Section heading, "as referred to in 
Subsection b" would need to be inside the enum-in-header for it to 
print in lower case. 
To insert an enum in the header tag: 

• Select Enum-in-header…Special Text and Symbols from the 
Insert menu; 

• Type text in the {enum-in-header} marker; 

• Type the enum in the casing it should print in.  Enum-in-
header appears in burgundy/dark red color on the screen; 

• Press the right arrow key on the keyboard to move the 
cursor out of the enum-in-header tag. 

The Header-in-Text tag 
The header-in-text tag is used when you need to insert a Header in the 
middle of text.  
For example, the words “In General” would need to be in the header-
in-text tags to print like a subsection header if the paragraph read, “(1) 
by inserting ‘(a) In General.—‘ before ‘The Secretary’; and”. 
To insert a Header in Text tag: 

• Select Header-in-text…Special Text and Symbols from the 
Insert menu; 

• Select the header level; 

• Type text in the {header-in-text} marker; 

• Type the header in sentence casing.  Header-in-text appears 
green in color on the screen; 

• Press the right arrow key on the keyboard to move the 
cursor out of the header-in-text tag. 
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  You may delete the header-in-text tags and the material contained within the tag by placing your cursor 
inside the comment and selecting delete level.  A dialog window is displayed that will allow you to only delete the 
tag instead of the level. 
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Inserting Member and Committee Names 
Certain bills and resolutions have Member and Committee names in 
the text of the legislation.  
To insert a Member's name in the text of the legislation: 

• Select Names…Members from the Insert menu, or press 
CTRL+SHIFT+M.; 

To insert a Committee name in the text of the legislative: 

• Select Names…Committees from the Insert menu, or press 
CTRL+SHIFT+C. 

Line Break 
To insert a page break: 

• Select Breaks…Line Break from the Insert menu, or press 
CTRL+L; 

• On screen, a forced line break will appear as a blue 
diamond.  Use the line break only when a forced line break 
is needed. 

Page Break 
To add a page break: 

• Select Breaks…Page Break from the Insert menu, or press 
CTRL+ALT+P; 

• On screen, a forced page break will appear in red with the 
words "FORCED PAGEBREAK"; 

To force two words to be printed on the same line: 

• Replace the space between the words with a fixed space or 
En-Space. 

To insert the En-Space: 

• Select En-Space from Special Text and Symbols on the Insert 
menu, or press CTRL+E. 
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Untagging elements 
Several elements can be converted back to plain text by removing the 
tags that surround the text.  Elements that can be untagged are:  italic, 
quote, inline-comment, internal-xref, header-in-text, enum-in-header, 
act-name, definition, subscript, superscript, and term. 
To untag elements: 

• Place your cursor in the element; 

• Select Un-tag the Item from the Edit menu, right-click with 
your mouse and select Untag, or press the F10 key. 

Attaching notes 
As a drafter, you may with to attach notes to a level as you work on 
your document. 
To create a note using XMetal:  

• Place the cursor in the level that the note should be attached 
to, 

• Select Attach Note from the Tools menu, or press CTRL+F10. 
An inline comment with the words [ATTACHED NOTE] will be 
inserted in the document.  This inline comment is hidden and will not 
appear on the printed copy of the document. 

• Notepad will open and you can type a note.  The notepad 
file is assigned a name automatically and is used to link the 
level and the note for retrieval later.  Do not change the 
name of the note; 

• Close notepad when finished; 
To view the note again: 

• Place your cursor in the inline comment [ATTACHED 
NOTE] and press CTRL+G.  The note will open in notepad. 
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Special Text and Characters 
Many of the keystrokes used in XyWrite to create special characters 
(and text) are replicated in XMetaL. 
To insert special characters: 

• Select Symbols/Special Chars/Images…Show Special 
Characters Toolbar from the Insert menu, or press 
CTRL+SHIFT+E; 

• The special characters toolbar will appear at the bottom of 
the window. 

To insert symbols: 

• Select Symbols/Special Chars/Images…Show Symbols 
Toolbar from the Insert menu; 

• The Symbols toolbar with appear at the bottom of the 
window. 

To use the Special Characters or Symbols Toolbar: 

• Place your cursor in the location where the special 
character is needed; 

• Click the character from the Special Characters toolbar. 
To move the symbols or special character toolbar: 

• Click the move handle on a docked toolbar, or click the title 
bar on a floating toolbar; 

• Drag the toolbar to a new location. If you drag the toolbar 
to the edge of the program window, it becomes a docked 
toolbar. 
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Under Special Text and Symbols on the Insert menu is a list of custom 
text inserts.  The table below briefly describes each one. 

Menu Item Description 
Text: United 
States Code 

Inserts the words "United States Code" 

Text: section Inserts the word "section" 

Text: paragraph Inserts the word "paragraph" 

Italic Type Formats italicized text. Type italicized text in the {italic} marker and 
plain text in the {text} marker. To return to plain text from italic text, 
use the right arrow key or click your mouse at the end of the italics.  To 
change italics to plain text use Untag the item from the Edit menu. 

— (em-dash) Inserts an em-dash 

– (en-dash) Inserts an en-dash 

§ (section 
symbol 6) 

Inserts a section symbol. 

Em-space 
(2003) 

Inserts an Em-space. [#x2003] is visible. 

En-space (2002) Inserts an En-space. [#x2002] is visible. 

$__________       Inserts the $ sign with a line ten spaces long. 

Current Date Inserts the current date. 

Header-in-text Use this feature when you need to insert a Header in the middle of text. 
Select Header-in-text, select header level, and type text in the {header-
in-text} marker. Type the header in sentence casing. Header-in-text 
appears green in color on the screen. 

Enum-in-header Use this feature when you need to insert an enumerator in a header that 
needs to print in a different case. For example, the letter b in the Section 
Heading, "as referred to in Subsection b" would need to be inside the 
enum-in-header for it to print in lower case. 

Fraction Formats a fraction. Select Fraction, and then type the fraction in the 
{fraction} marker. 

Superscript Formats text in superscript. Select superscript, then type text in the 
{superscript} marker. Superscript appears superscript on the screen.  
Use the right arrow key or mouse click to escape from superscript. 

Subscript Formats text in subscript. Select subscript, then type text in the 
{subscript} marker. Subscript appears subscript on the screen.  Use the 
right arrow key or mouse click to escape from subscript. 



Congressional Help Working with Tables  •  100 

Working with Tables 

XMetaL Tables Overview  
Basic Table Characteristics 
There are a few basic characteristics of tables that you should know 
before you begin creating tables in XMetaL. 

Column Types 
There are 2 basic column types that are used in tables and these are 
text columns and figure columns. An important thing to remember 
about column types is that it is not the content of a column that 
determines the column type. The column type is defined by its 
alignment and whether or not it contains leaders. 

Text Columns 
Text columns will align to the left and will be leadered. 

Figure Columns 
Figure Columns will align to the right and will not be leadered. 
5 Column Military Table 
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What it looks like in XMetaL 

 

The table templates found in XMetaL already have their column types defined and it will only be necessary to 
change the column type if you wish to create a table that is different from the template.  If you change the alignment 
of a column to Center, the column will still keep its original type definition. 

What are Leaders? 
Leaders are the dots that fill the space in a column following the data. 
These dots “lead” your eye to the next column and help to show which 
row your data is aligned with. 

 
Centering – Text in cells that have been aligned to the center will not 
leader unless the cell is in a figure column and is empty 
Last Column – Leaders do not display in the last column of a table 
unless the last column is a figure column and the cells are empty. 
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Header Rows and Table Body Rows 
• Header Row - A header row is the row or rows at the top of 

the table that contain the column headings. The size and 
format of the text in this type of row is usually different 
from that in table body rows. The text in a header row is 
always centered and does not leader and this cannot be 
changed. When you use the tab key while the cursor is at 
the end of a header row, another header row will be 
inserted; 

• Table Body Row – A table body row is any row in a table 
that is not a header or footnote row. Table body rows are 
the rows that contain your data; 

• Footnote Row – A table footnote row is a row at the bottom 
of a table that is reserved for footnotes. This type of row is 
not included in most table templates but can be added using 
the interface when needed. 
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Column and Row Separators 
The term “separator” is used to describe lines that are used to separate 
columns, rows or cells from one another. Row separators are the 
horizontal rules that separate rows and they are sometimes referred to 
as row rules.  Column rules are the vertical lines that separate columns 
and are sometimes referred to as column separators.  

 



Congressional Help Working with Tables  •  104 

Advanced Table Characteristics 

Spanning Columns 
A column that spans is one where the data in the column is allowed to 
spread across the table into the space where a new column would 
usually begin. There are no column separators used in a spanning 
column. The data in a spanned column belongs to the first column 
where the span begins.  
Spanning Example 1 – Column 1 in Row 4 Spans 3 Additional 
Columns 

 
 
Spanning Example 2 – Column 2 in Row 4 Spans 1 Additional 
Column 
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Creating Spanning Columns in a Table 
The merge cell function is used to create columns that span. The 
merge cell function is accessed through the Merge icons on the 
XMetaL toolbar. The Merge Cell Right icon is the one that is used to 
span columns from left to right. The merge cell function can be used to 
span columns in header and/or table body rows. 

 
In the table example below, the data in the last column spans 3 
additional columns. 

 
To create a table with columns that span: 

• Select a template and insert your table; 

• Enter your headings and data; 

• Click inside the cell where you wish to begin the span; 
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• Click the Merge Cell Right Icon on the XMetaL toolbar 
once for each additional column you wish to span across. If 
you wish to span vertically, click on the Merge Cell Down 
Icon. 

 
 

• Render the table. 

 
 
Rendered Table Example 



Congressional Help Working with Tables  •  107 

Multi-Level Headings 
Tables with multi-level headings are those that have more than 1 
header row. When a table has a multi-level boxhead, the heading in the 
first column almost always spans vertically to take up additional 
header rows in the column. The headings for subsequent columns are 
usually divided between 2 or more heading levels. The maximum 
number of heading levels a table can contain is 9. 
 
Multi-level Heading Example– 2 Levels 

 
 
Multi-level Heading Example– 5 Levels 

 

Creating Multi-Level Headings in a Table 
In the table example below, the headings “Number in College” and 
“Family Members” are both level 1 headings. This is because they 
both begin in the first header row. The headings, “1” and “2” both 
begin in the second header row and are therefore level 2. In addition to 
having multi-level headings, some of the headings also span. The 
heading, “Number in College” spans an additional column and 
“Family Members” spans vertically through an additional row.  
Table with a Multi-level Headings that Span 
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To create a table with multi-level headings that span: 

• Select a template and insert your table; 

 
• Add an additional header row by using the tab key when 

your cursor is positioned in the last column in the header 
row; 

 
 

• Click “Yes” in the insert header dialog box; 

• Click inside the cell where you would like the span to 
begin; 

 
• Click once on the Merge Cell Right Icon on the XMetaL 

toolbar. If you wish to span vertically, click on the Merge 
Cell Down Icon; 

 
• Type the new column headings and delete the {Table Head 

Entries} you do not want; 
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• Enter table data; 

 
• Render the table. 

 
 

Rendered Table Example 
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Spans that are Allowed in Multi-level Boxheads 
 
When creating a table, most people arrange headings and spans so that 
larger ideas divide into smaller as more levels of header rows are 
added. Due to limitations in Bellcode, the types of spans that can occur 
in a table are limited to spans where the larger span is on top and 
smaller spans are beneath. The table excerpt below is an example of a 
table with typical spanning. 
 
Example 1 - Typical Spanning 
 

 

Spans that are NOT allowed in Multi-level Boxheads 
The following tables are examples of tables with spans that are not 
allowed. Although you can create these types of spans in XMetaL, 
tables that contain them will not render.  
Example 1 – Large Span below Smaller 
 

 
Example 2 – Large Span below Smaller 
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Example 3 – Span Split Halfway between Heading Entries 
 

 

Quoted Tables 
To insert a table that is inside a quoted block, you must first insert the 
quoted block through the Insert menu on the XMetaL Toolbar Menu or 
by clicking on the Insert Quoted Block icon on the toolbar. 
To insert a table inside a quoted block: 

• Select Insert » Quoted Text Block from the XMetaL Toolbar 
Menu or click on the Quoted block icon on the toolbar. 

 
• Select the Table checkbox in the Insert Quoted Text form; 
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• Click on the word Section in the box below the Table 
checkbox; 

• Click on the Remove button; 

• Click OK. 
This will launch the table creation form and you may choose your 
template and proceed with table insertion. 

Quoted tables will be displayed with blue text in XMetaL and will also 
be labeled with a tag that shows the style of the quoted block that the 
table will appear in. The punctuation that will be included in the last 
cell of the table will be shown following the “End-Of-Quoted-Block” 
tag. 
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Tax Calculations 
The only table type that currently uses an automatic calculation feature 
is the 2 Column Tax Rate Table. A Tax Table Calculator form is 
launched when you select the 2 Column Tax Rate Template and click 
ok. Once you complete this form and click ok, the table will be 
inserted and will be pre-populated with data based upon the numbers 
you have entered. 

 
Once you complete this form and click ok, the table will be inserted 
and will be pre-populated with data based upon the numbers you have 
entered. 
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Creating a 2 Column Tax Rate Table: 
 

• Select the 2 Column Tax Rate template; 

• Click OK. A calculation form is displayed; 

 
• Enter the dollar amount for taxable income in the first box. 

(Do not include dollar signs or commas); 

• Enter the percentage of taxable income in the second box; 

 
• Click inside the checkbox on the left side of the form if you 

wish to add another row and then fill out the taxable 
amount and taxable income percentage information as you 
did in the previous row. Repeat this step until the table 
contains the number of rows needed; 
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• Click OK to insert the table. 

 

The data on the last line is for informational purposes only and will not be included in the table. 

 

Editing a Tax Rate Calculation 
Once a tax rate table has been inserted is still possible to edit the 
figures used when the table was created. This is done through the Edit 
Tax Table function that is accessible through the table menu in 
XMetaL. 

 

  
To edit a tax table calculation: 

• Select Edit Tax Table Calculation from the Table menu. 
This will launch the same Tax Table Calculator form that 
was used when you first created the table. The form will be 
pre-populated with the figures that were used when the 
table was created. 
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• Change figures as needed and click OK. The table will then 
be updated with the new calculation. 
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Using the Table Creation Interface 
Inserting a Table 

• Select Insert Table from the Table menu on the XMetaL 
toolbar, or press Ctrl+Shift+F5. 

 
This will launch the Table Creation form 

 



Congressional Help Working with Tables  •  119 

Selecting and Using a Template 
Templates have been provided for most of the table types that 
commonly appear in bills. Characteristics for such things as column 
widths, leadering, and table rules are already set in the template based 
on most common usage but any of these characteristics may be 
changed. 
To select a template: 

• Select the number of columns by clicking on the arrow on 
the right side of the General drop-down menu and making a 
selection or by typing the desired number of columns in the 
box; 

 
• Select a template by clicking on the arrow on the right side 

of the Specific drop-down menu and making a selection. 

 

A selection must be made in the Number of Columns drop-down before a selection can be made in 
“Template”. 
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• Click OK at the bottom of the Table Creation form once a 
template has been selected. Your table will be inserted. 

Table Creation Form with Table Characteristics Defined in the Template

 

Viewing A Table Example 
A table Example feature is available when you select a table template 
so that the various table types may be viewed prior to inserting a table. 
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To view a table example: 

• Click the Example button to display a picture of the table 
type that has been selected using the Table Type drop-down 
menus; 

 
• A window is displayed that shows you how the table will 

look; 

 
• You can change the view by modifying the number of Rows by 

using the up and down arrows on the right side of the 
Number of Rows control or by typing a new number in the 
box; 

 
• Click OK when you have finished viewing the example. 
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Entering Table Data 
The table below is an empty 4 Column Military table (No Total) as it 
appears in XMetaL. 

 
• Enter a Table Title by clicking once in the gray highlighted 

area above the table that is labeled {Table Title} and then 
typing the desired text for the Table Title. (The gray 
highlight will turn black once you click on it and you may 
then begin typing); 

• Enter Column Headings by clicking once in the gray 
highlighted area in a cell labeled “{Table Head Entry}” and 
then typing the desired text for the column heading.  (The 
gray highlight will turn black once you click on it and you 
may then begin typing); 

 
• Enter Table Cell Content by placing the cursor in any cell in 

the table and typing the desired text. You can move 
between cells (from left to right) by using the tab key; 
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Copying and Pasting Cell Data 
• Select the text you wish to copy by clicking and dragging; 

• Click on the Copy icon on the Toolbar; 

• Click on the new location where the text is to appear; 

 
• Click on the Paste icon on the toolbar, or select Paste from 

the right-click menu. 
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Adding Rows at the end of a table 
• Place your cursor in the last cell in a row using the Tab key 

to add more rows at the end of a table. 

 
This will insert a single additional row each time the tab key is used as 
long as the cursor is at the end of a row that is at the end of the table. 

Adding Rows in the middle of a table 
• Place your cursor in the last cell in a row using the Tab 

key; 

 
• Select the Insert Row Above or Insert Row Below icons on the 

XMetaL toolbar to insert more rows in a table. 

 
This will insert a single additional row. 
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Deleting A Row 
• Click in any cell inside the row that is to be deleted; 

 
• Select Delete Row from the Table menu on the XMetaL 

Toolbar. The row and all of its content will be deleted from 
the table. 

Deleting Data within a cell: 
• Place the cursor inside the table before the text to be 

deleted; 

• Use the Delete key until the text has been removed, or; 

• Click and Drag to select the text that is to be deleted, and; 

• Right click and select Delete from the menu. 
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Deleting the contents of a row or rows: 
• Click and Drag from left to right across all of the cells in 

the row to select all of the row content; 

 
• Right click and select Delete from the menu. 

 

Deleting the contents of a column: 
• Click and Drag from left to right in the first cell in the 

column and then drag from the top of the column to the 
bottom of the column to highlight all of the data in the 
column.; 

 
• Right click and select Delete from the menu. 
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Deleting A Table 
• Place the cursor inside any cell inside the table; 

 
• Select Delete Table from the Table menu on the XMetaL 

Toolbar, or; 

 
• Place the cursor inside any cell inside the table; 

• Right click; 

• Select Delete Table from menu. 

No text should be selected when attempting to delete a table. When text is selected during table deletion, only 
the selected text will be removed and the table will remain in the file. 
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Print Preview 
To view a table as it will be printed: 

• Place the cursor in any cell of the table you wish to view; 

 
• Right click and select Table Preview from the menu; 

 
• A status bar will then be displayed to show the progress of 

the table rendering process; 

 
• When the rendering process is complete, Adobe Acrobat 

will be launched and the table will be displayed in a new 
window. 

Only one table may be rendered at a time. It is important to close any table previews that are open in Acrobat 
before rendering another. 

Resume Working in XMetaL 
To resume working in XMetaL after a table has been rendered, click 
on the XMetaL icon in the taskbar at the bottom of the screen. 
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Table Customization in the Table Creation Form 
Column Headings 
To include column headings in your table: 

• Click once inside the Column Headings checkbox. 

 
A checkmark will be displayed inside the box when Column Headings 
will be included.  Bold column headings are created by checking the 
“Bold” checkbox next to the Column Headings checkbox. 

  If the Column Headings box is checked and you do not wish to include column headings in the table, click 
once inside the box to deselect this option. 

Table with Column Heading and Rules 

 
Table without Column Heading but with Rules 

 
Table without Column Headings or Rules 
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Creating A Table Title 
To include a title above your table: 

• Click once inside the Table Title checkbox. 

 
A checkmark will be displayed inside the box when a table title will be 
included in the table.  Bold table titles are created by checking the 
“Bold” checkbox next to the Table Title checkbox. 

If the Table Title box is checked and you do not wish to include a title in the table, click once inside the box to 
deselect this option. 

Table with Table Title 

 
 
Table without Table Title 
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Creating A Table Subtitle 
To include a subtitle above your table: 

• Click once inside the Table Subtitle checkbox.  

 
A checkmark will be displayed inside the box when a table subtitle will 
be included in the table. 

If the Table Subtitle checkbox is checked and you do not wish to include a subtitle in the table, click once 
inside the box to deselect this option. 

Table with Subtitle 
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Adding Table Footnotes 
To include footnotes in your table: 

• Click once inside the Footnotes checkbox. 

 
A checkmark will be displayed inside the box when footnotes will be 
included in the table. 

If the Footnotes checkbox is checked and you do not wish to include footnotes in the table, click once inside 
the box to deselect this option. 

Table with Footnote 
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Modifying Vertical Table Spacing 
The vertical space before control allows you to add white space 
between the table and the text that precedes it. 

 
The vertical space after control allows you to add white space between 
the table and the text that follows it. 

Font Sizes 

 
To select the size of the font for the entire table body: 

• Click on the arrow in the Table Point Size drop-down 
menu; 

• Choose a point size from the list and click on it. 
To select the size of the font for just the column headings: 

• Click on the arrow in the Heading Point Size drop-down 
menu; 

• Choose a point size from the list and click on it. 
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Rules Controls 
The Borders controls allow you to select which rules you would like to 
display in your table.  You may choose the individual rules that you 
would like to include in your table by checking the appropriate 
checkbox or checkboxes. (The checkboxes will be pre-populated 
according to the table type you have chosen. You may change the 
defaults and customize your table rules using these controls.) The 
Border Preview box on the left will change according to which 
checkboxes you have checked and will show an example of the rules 
combination currently selected. 
Rules Controls - Table Creation Form 

 
Table Rules Examples - All checkboxes are checked 

 
All Checkboxes are Unchecked 

 
The Top of Table and Bottom of Header Checkboxes are Checked 
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Table Properties 
Table Level Properties 
The Ctrl-Shift-F6 key sequence is used to access the Table Properties 
form. This is where you can make changes a table after it has been 
inserted in a document.  Many of the same controls found in the Table 
Creation form also appear Table Properties under the Table tab. 
You can choose to make changes at table, column, row, or cell level by 
clicking on the tabs in the upper left hand corner of the Table 
Properties Form. 
Table Level Table Properties Form 

 
Align to Level 

 
Most tables are aligned to section level by default. The Align to Level 
control allows you to override section alignment and choose the level 
to align your table with. This feature can only be used in tables 
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containing less than 3 columns. Choose the level you wish to align 
with from the Level drop-down menu. (Section, subsection or 
paragraph are the available choices.)  In the example below, the first 
table was inserted aligned with a clause instead of with the section. 

If you wish to use the Align to Level Feature, it is recommended that you also use the Absolute Width function 
in Advanced Features to help prevent your table from changing to landscape orientation. Column width changes 
may also be required. Please also note that tables that are aligned to level align to the text of the selected level, not 
the enumerator. 
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Tables Inserted Using Align to Level 
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Vertical Space Controls 

 
• Before - The vertical space before control allows you to 

add white space between the table and the text that 
precedes it; 

• After - The vertical space after control allows you to add 
white space between the table and the text that follows it. 

Using Table Rules 
The Borders controls allow you to select which rules you would like to 
display in your table.  You may choose the individual rules that you 
would like to include in your table by checking the appropriate 
checkbox or checkboxes. (The checkboxes will be pre-populated 
according to the table type you have chosen. You may change the 
defaults and customize your table rules using these controls.) The 
Border Preview box on the left will change according to which 
checkboxes you have checked and will show an example of the rules 
combination currently selected. 
 Rules Controls - Table Creation Form 
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Components and Font Sizes 

 
To select the size of the font for the entire table body: 

• Click on the arrow in the Table Point Size drop-down 
menu; 

• Choose a point size from the list and click on it. 
To select the size of the font for just the column headings: 

• Click on the arrow in the Heading Point Size drop-down 
menu; 

• Choose a point size from the list and click on it. 
To include column headings in your table: 

• Click once inside the Column Headings checkbox. (A 
checkmark will be displayed inside the box when Column 
Headings will be included) Bold column headings are 
created by checking the “Bold” checkbox next to the 
Column Headings checkbox; 

• If the Column Headings box is checked and you do not 
wish to include column headings in the table, click once 
inside the box to deselect this option. 

To include a title above your table: 

• Click once inside the Table Title checkbox. (A checkmark 
will be displayed inside the box when a table title will be 
included in the table.) Bold table titles are created by 
checking the “Bold” checkbox next to the Table Title 
checkbox; 

• If the Table Title box is checked and you do not wish to 
include a title in the table, click once inside the box to 
deselect this option. 

To include a subtitle above your table: 

• Click once inside the Table Subtitle checkbox. (A 
checkmark will be displayed inside the box when a table 
subtitle will be included in the table); 
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• If the Table Subtitle checkbox is checked and you do not 
wish to include a subtitle in the table, click once inside the 
box to deselect this option. 

To include footnotes in your table: 

• Click once inside the Footnotes checkbox. (A checkmark 
will be displayed inside the box when footnotes will be 
included in the table); 

• If the Footnotes checkbox is checked and you do not wish 
to include footnotes in the table, click once inside the box 
to deselect this option. 
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Column Level Properties 
The Column Level Table Properties form is where you can make 
changes that will affect all of the data in an individual column. 
Column Level Table Properties Form 

Column Tab

 

Varied 
There are several controls on the Column Level Table Properties form 
that may sometimes display a value of “varied”. The controls that may 
sometimes have this value are Leaders, Alignment, Indent, and Row 
Sep. A value of “varied” simply means that all of the cells in the active 
column do not have the same setting. This is because settings at row or 
cell level have been changed and are no longer the same as the value at 
column level. If a new value is set in the Column Level Table 
Properties form, the previous row and cell level settings will be 
overwritten with the values from column level.  
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Column Description 

 
The column box shows the name of the column you are currently 
working in. 
To change the width of a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Type the desired width in the Column box. The width value 
must be a number. 

To change the width of a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Type the desired width in the Column box. The width value 
must be a number. 

To change the leadering settings for the entire column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click on the arrow next to the Leaders box; 

• Select either “on” or “off” from the drop-down list. 

 Leaders cannot be turned on or off in figure columns 
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Table with Leaders 

 
Table without Leaders 

 

Using Column Alignment 

A.

C.

B.

D.

 
The Alignment drop-down box allows a choice of left, right, or center 
and all cells in the column will be aligned according to the selection in 
this drop-down box.  
To set the alignment for every cell in a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click on the arrow next to the Alignment box; 

• Select “left”, “right”, or “center” from the drop-down list. 
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The Indent level drop-down box is where you can control how far to 
the right your data will appear from the left side of the cell border. 
You may choose a level from 2 to 9. (Level 2 has the least indent, 9, 
the most.) The default for most tables is to have level 1 indent and the 
choice of “1” is only available in cases where the column has an indent 
level other than 1. The table example below shows the 9 available 
levels of indention. 
Indention Levels 

 
To set the indent level for every cell in a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click once inside the Para Style checkbox; 
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To select paragraph style indention in every cell in a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click once inside the Para Style checkbox; 

Paragraph Style

  This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

 

 When paragraph style alignment is selected, the “center” checkbox and indent level controls will be 
disabled. 

The spread control is what determines whether or not a column will be 
allowed to expand in order to accommodate the amount of data that 
has been keyed in the column. The choices are limited to “on” or “off” 
for each column. Choosing “on” will allow the column to spread to fit 
the data and choosing “off” will prevent the column from spreading. 
To set the spread for a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click on the arrow next to the Spread box; 

• Select “on” or “off”. 
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Using Column Level Rules  

A.

B.

C.

 
 

The Col Rules control allows you to choose whether or not there will 
be a vertical rule following a column. In the example below, the 
vertical rule following Column 2 has been turned off using the Col 
Rules control. 

 
To turn vertical rules on or off following a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click on the arrow next to the Col Rules box; 

• Select “on” or “off”. 
Tables that have vertical rules always have single rules as a default. 
The Rule Style drop-down allows you to change a column rule from a 
single rule to a parallel rule.  
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To change the style of a vertical rule following a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click on the arrow next to the Rule Style box; 

• Select “parallel”. 
The Row Sep control will allow you to add a horizontal rule to every 
cell in the column. This rule will appear underneath the data. In the 
example below, row separators are turned on in column 3. 

 

To control row separators at column level: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Column from the right-click menu; 

• Click on the arrow next to the Row Sep box; 

• Select “on” or “off”. 



Congressional Help Working with Tables  •  148 

Row Level Properties 
The Row level Table Properties form is where you can make changes 
that will affect all of the data in a single row.  
Row Level Table Properties Form 

 

Varied 
There are several controls on the Row Level Table Properties Form 
that may sometimes display a value of “varied”. The controls that may 
sometimes have this value are Indent Lvl, Leaders, and Row Sep.  A 
value of “varied” simply means that all of the cells in the active row do 
not have the same setting. This is because settings at cell level have 
been changed and no longer have the same as the other cells in the 
row. If a new value is set in the Row Level Table Properties form, the 
previous cell level settings will be overwritten with the values from 
row level. Changes made at row level will also overwrite previous 
column level values.  
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Row Specifications 

The Active Row box shows the name of the row you are currently 
working in. 
The Indent Level drop-down box is where you can control how far to 
the right your data will appear from the left side of the cell border. 
You may choose a level from 2 to 9. (Level 2 has the least indent, 9, 
the most.) The default for most tables is to have level 1 indent and the 
choice of “1” is only available in cases where the column has an indent 
level other than 1. The table example below shows the 9 available 
levels of indention. This control sets the indent for every cell in the 
row. 
Indention Levels 

 
To set the indent level for every cell in a column: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Row from the right-click menu; 

• Click on the arrow next to the Indent Lvl drop-down box; 

• Select a value from 2 to 9. 
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The Para Style checkbox allows you to use paragraph style indention in 
every cell in the row.  

Paragraph Style

  This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

 
To select paragraph style indention in every cell in a row: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Row from the right-click menu; 

• Click once inside the Para Style checkbox; 

When paragraph style alignment is selected, the “center” checkbox and indent level controls will be 
disabled. 

To change the leadering settings for the entire row: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Row from the right-click menu; 

• Click on the arrow next to the Leaders box; 

• Select either “on” or “off” from the drop-down list. 

Leaders cannot be turned on or off in figure columns when they are aligned to the right or centered. 
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Table with Leaders 

 
Table without Leaders 

 
The Row Sep drop-down box is where you can turn row separators on or 
off in every cell in the row without having to make changes to every 
individual cell. In the example below, row separators are turned on in 
row 1, 2, and 4 but are turned off in row 3. 

 
To turn row separators on or off in an entire row: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Row from the right-click menu; 

• Click on the arrow next to the Row Sep box; 

• Select “on” or “off”. 
Tables that have row separators always have single rules as a default. 
The Row Sep Style drop-down allows you to change a row separator 
from a single rule to a bold or a double rule.  
The Center checkbox will Center all of the data in every cell in the row 
when it is checked. 
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Cell Level Table Properties 
The Cell level Table Properties form is where you can make changes 
that will affect only the data in a single cell.  
Cell Level Table Properties Form 

Cell Tab

 

Cell Specifications 

 
The Active Cell box shows the name of the Column, Row, and Cell you 
are currently working in. 
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The Alignment checkbox allows a choice of left, right, or center the 
data in the cell you are currently working in will be aligned according 
to the selection made in this drop-down box.  
To set the alignment for the data in an individual cell: 

• Right click anywhere in the cell you wish to change; 

• Select: Table Properties » Cell from the right-click menu; 

• Click on the arrow next to the Alignment box; 

• Select “left”, “right”, or “center” from the drop-down list. 
The Indent Level drop-down box is where you can control how far to 
the right your data will appear from the left side of the cell border. 
You may choose a level from 2 to 9. (Level 2 has the least indent, 9, 
the most.) The default for most tables is to have level 1 indent and the 
choice of “1” is only available in cases where the column has an indent 
level other than 1. The table example below shows the 9 available 
levels of indention. This control sets the indent for every cell in the 
row. 
Indention Levels 

 
To set the indent level an individual cell: 

• Right click anywhere in the cell you wish to change; 

• Select: Table Properties » Cell from the right-click menu; 

• Click on the arrow next to the Indent Lvl drop-down box; 

• Select a value from 2 to 9. 
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To select paragraph style indention in an individual cell: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Cell from the right-click menu; 

• Click once inside the Para Style checkbox; 

Paragraph Style

  This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

 

When paragraph style alignment is selected, the “center” checkbox and indent level controls will be 
disabled. 

To change the leadering in an individual cell: 

• Right click anywhere in the cell you wish to change; 

• Select: Table Properties » Cell from the right-click menu; 

• Click on the arrow next to the Leaders box; 

• Select either “on” or “off” from the drop-down list. 

Leaders cannot be turned on or off in figure columns. 
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Table with Leaders 

 
Table without Leaders 

 
The Row Sep drop-down box is where you can turn row separators on or 
off. 
To turn row separators on or off in an individual cell: 

• Right click anywhere in the column you wish to change; 

• Select: Table Properties » Cell from the right-click menu; 

• Click on the arrow next to the Row Sep box; 

• Select “on” or “off”. 
Tables that have row separators always have single rules as a default. 
The Row Sep Style drop-down allows you to change a row separator 
from a single rule to a bold or a double rule. 
Checking the Center checkbox will center the data in the cell you are 
working in. 
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Column Overview 
Accessing Column Overview 
Column Overview can be launched by clicking the “Col Overview” 
button at the bottom of the Table Creation form. (To access this form 
after the table has been inserted, right-click anywhere inside the table 
and select Table Properties » Column from the right-click menu and 
then click on the Column Overview button underneath the rules 
controls.) 
Figure 1 – Accessing the Column Overview Form 

 

Using Column Overview 
The Col Type, Width, Leaders, Rules, and Spread boxes already 
contain values that are specific to the template for the table type that 
was chosen in the Table Creation Form. Each of these can be changed 
if desired. 
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Column Overview form with Table Characteristics Defined in the 
Template 

 
• OK – Click OK at the bottom of the form to insert the table 

without making changes. 

• Go Back – Click on the Go Back button at the bottom of 
the form to return to the Table Creation form instead of 
inserting a table. A different table type can then be chosen. 
Click Cancel at the bottom of the Table creation form if 
you wish to exit the form without inserting a table. 

• The available choices in the Col Type menu are limited to 
text or figure and may be chosen from the drop-down list. 
This simply determines whether the content of the column 
will be treated as text, or as numbers. As a general rule, all 
columns designated as text will align to the left and all 
columns designated as figures will align to the right. 

To change the column type: 

• Click on the arrow next to the Col Type box beneath the 
column number of the column you wish to change; 

• Select either “text” or “fig” from the drop-down list. 

 
A column Width must be specified for each column in the table.  
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To change the width of a column: 

• Click inside the Width box that appears beneath the column 
number of the column you wish to change; 

• Type a new value for the column width in the box. (The 
value for column width must be a number and is expressed 
in points.) 

Columns that have been designated as “text” in the Column Overview 
form are the only columns where changing the Leader controls will 
have effect.  
Leaders 

 
To add or remove leader dots from a column: 

• Click on the arrow next to the “Leaders” drop-down menu 
beneath the column number of the column where you wish 
to make a change; 

• Click on “yes” or “no” to make your selection. 
Col Sep (Column Separators) 

 
The Col Sep control allows you to choose whether or not there will be 
a vertical rule following a column.   
To turn column separators on or off in a column: 

• Click on the arrow next to the “Col Sep” drop-down menu 
beneath the column number of the column where you wish 
to make a change; 

• Click on “on” or “off” to make your selection. 
Spread 

 
The Spread control is what determines whether or not a column will be 
allowed to expand in order to contain the amount of data that has been 
keyed in the column. The choices are limited to “on” or “off” for each 
column. Choosing “on” will allow the column to spread to fit the data 
and choosing “off” will prevent the column from spreading. 
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To turn spread on or off in a column: 

• Click on the arrow next to the “Spread” drop-down menu 
beneath the column number of the column where you wish 
to make a change; 

• Click on “on” or “off” to make your selection. 
To insert a table once changes have been made: 

• OK – Click OK to insert the table; 

• Go Back – Click Go Back if you wish to return to the Table 
Creation form instead of inserting a table. 

Align 

 
The Align drop-down boxes allow a choice of left, right, or center and 
all cells in the column will be aligned according to the selection in this 
drop-down box.  

To set the alignment for every cell in a column: 

• Click on the arrow next to the Alignment box; 

• Select “left”, “right”, or “center” from the drop-down list. 
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Advanced Features 
Advanced Table Features 
To access advanced features from the table creation interface: 

• Click the Advanced button at the bottom of the Table 
Creation Form; 

 
The Advanced Features form can also be accessed through table level 
table properties via the right-click menu after a table has been inserted. 
To access advanced features through the right-click menu: 

• Right click anywhere inside the table; 

• Select, Table Properties » Table from the right-click menu; 

• Click on the Advanced button on the bottom right of the 
Table level Table Properties form. 
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Using Advanced Features 

 

Special Features 
Vertical Justify 

 
Vertical Justify is a feature that creates additional vertical space within 
the allowed table parameters to increase the readability of a table. This 
feature will be on by default and the box will be checked. To override 
vertical justification, uncheck the Vertical Justify checkbox.  
Restrict Indent 

 
The Restrict Indent checkbox is used to override default MicroComp 
indent behavior and will restrict indents in the first column to 1 em 
regardless of the width of the column. When indents are restricted, the 
amount of space between one level of indention and another will not 
increase beyond 1 em as higher levels of indention are used.  For 
example, if level 1 indention has been used for the first entry in a row 
and level 2 indention is used for the entry in the row below it, the entry 
with level 2 indention will align with the hanging data in the first entry 
instead of being further indented to the right. 
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Normal Indent 

 
 Restricted Indent 

 
Min Top Space 

 
When the Min Top Space or “minimum top space” checkbox is 
checked, a table will be inserted without any additional space being 
added between the table and the text that precedes it.  This box will be 
unchecked by default so that most tables will be inserted with 
additional vertical space above. 
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Leader from Top 

 
The Leader from Top checkbox can be used to allow leader dots to 
align from the top of the entries in a preceding column instead of the 
bottom. (This is only evident if the entry is long enough to wrap to 
more than 1 line.) Tables that contain a text column and 1 or more 
figure columns are the only tables that would require the use of this 
feature in order to leader from the top as tables with more than 1 
reading column will already leader from the top by default.) The data 
in subsequent figure columns will align to the top with the leaders as 
well. 
Advanced Leadering Examples 
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Block Style 

 
The Block Style checkbox can be used to align all data in a cell flush 
with the left margin instead of in the standard flush and hang style 
where only the data in the first line is flush with the margin and all 
data on subsequent lines “hangs” underneath with an indent of 1 em.  

This text is indented
flush and hang style.
It has no indent
between the first line
of text and the left
margin. The
following line has an
additional em space
indent and all
subsequent lines of
text are indented
flush with the
second text line.

Flush and Hang Paragraph Style

 This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

This text is indented
paragraph style.  The
first line is indented
from the left margin
but all subsequent
lines are flush with the
margin.

This text is indented
block style.  It will
align flush left
regardless of where
the line breaks.  It will
be indented in this
manner when a “bl” is
present in the function
line.

This text is indented
block style.  It will
align flush left
regardless of where
the line breaks.  It will
be indented in this
manner when a “bl” is
present in the function
line.

Block Style

 
Table with Flush and Hang Indention 
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Table with Block Style Indention 

 
Auto-hyphenation is the function that determines where a word will 
break when data does not fit on one line. The system determines the 
best position to break a word and inserts a hyphen in the chosen spot. 
(The hyphenation system uses a comprehensive hyphenation 
dictionary to make the determination.) The remainder of the word is 
set on the next line.  
Auto-Hyphenation 

 
Auto-Hyphenation will be on as a default but can be turned off by un-
checking the Auto-Hyphenation checkbox. 

This feature only pertains to the first column in the table. 

Use Actual Column Widths 
The Use Actual Column Widths checkbox is used to limit the spread 
of the columns to the column width values specified by the user. 
Columns in the table will no longer be allowed to spread to use up the 
width of the page when this box is checked 

Horizontal Justify 
Horizontal Justify is a feature that spreads data to fill the entire width 
of a column. This feature will be automatically used in text columns 
that are less than 12 ems wide but will be off by default when columns 
widths are more than 12 ems. The Horizontal Justify checkbox can be 
used to alter the justification that is being used in the table.  

This feature only applies to text columns 
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Font Sizes, Cell Spacing and Subformats 
The Table Title Size drop-down menu determines the size of the font 
that will be used for the table title. The larger the value, the larger the 
font will be. 
To change the size of the table title from the Advanced Form: 

• Click on the arrow at the right side of the Table Title Size 
drop-down box; 

• Select a font size from the menu; 

• Click OK. 
The Padding control is what determines how much space there will be 
between the data in a cell and the left and right margins of that cell. 
To change the amount of space between cell data and left and right cell 
margins: 

• Click on the arrow at the right side of the Padding drop-
down box; 

• Select a number from the menu. (The larger the number is 
the more cell padding there will be. The available values 
represent the amount of space and are expressed in points); 

• Click OK. 
The Leading control determines the amount of vertical space between 
the data in a cell and the top and bottom margins of that cell.  
To change the amount of space between cell data and top and bottom 
cell margins: 

• Click on the arrow at the right side of the Leading drop-
down box; 

• Select a number from the menu. (The larger the number is 
the more leading there will be. The available values 
represent the amount of space and are expressed in points); 

• Click OK. 
The Footnote Point Size drop-down menu determines the size of the 
font that will be used for table footnotes. The larger the value, the 
larger the font will be. 
To change the size of table footnotes from the Advanced Form: 

• Click on the arrow at the right side of the Footnote Point 
Size drop-down box; 

• Select a font size from the menu; 
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• Click OK. 
The Subformat control is an advanced feature that specifically pertains 
to Bellcode and is primarily for Government Printing Office use. 
Advanced users who are familiar with the function of subformats can 
enter the 4 digit number for the subformat they wish to use in the 
Subformat text box.  The subformat text box will show which 
subformat the table you are currently working in is in.  

Changing the subformat will change the default values for many table parameters. 

 
 
 
 
 
The Restore Default Settings Button restores all table settings to the 
state when the table was initially inserted. This means that any changes 
made to font size, column widths or types, spread, indent, or rule style 
and display will be lost. The restore default settings feature can be 
used when changes that have been made to a table cause it not to 
render or cause the file you are working in to become invalid. When a 
change cannot be undone because it cannot be determined which 
change caused the problem, this feature will allow you to start over 
without losing the data that has been entered in the table.  

Saving and validating your file frequently will make it easier to determine which change caused a problem in 
cases where a table won’t render. 

Template Utilities 
Template Utilities allow you to create and add new templates, modify 
existing templates, add preview examples to templates, delete 
templates that are no longer in use, or restore modified table templates 
to their original specifications. Table templates can also be shared 
using the import/export functions that are available through template 
utilities. 

Accessing Template Utilities 
To access Template Utilities: 

• Use the F12 key while holding down Ctrl and Shift, or; 

• Select Table from the Template Utilities menu on the 
XMetaL table menu, or; 
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• Right click anywhere inside the table you wish to create a 
template for and then select “Create a Template” from the 
right-click menu. 

Using Template Utilities 

 

Create Table Template 
To create a new table template: 

• Click on the “Create a Template” button on the Template 
Utilities form while your cursor is positioned inside a table; 

• This will launch the Table Template Creation Wizard; 
The Table Template Creation Wizard will allow you to save the table 
you are working in as a template that will be available through the table 
type menu in the Table Creation Interface. Table examples can also be 
added through the Table Template Creation Wizard, and once added 
can be viewed by clicking the “Example” button in the Table Creation 
form while the corresponding template is selected in the template drop-
down menu.  
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• Step 1 - What would you like to do? 

The selection made in the “What would you like to do?” box will 
determine whether you will add a new template with a new name to the 
table menu system or whether you wish to use your template to replace 
an existing template and use its name.   
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• Create a New Template 
If you are creating a new template you must type a name for the 
template in the template name box. The name for the new template 
cannot have the same name as an existing template. 

 
• Replace an Existing Template 

If you wish to replace an existing template with the one you are 
creating, click on the name of the template you wish to replace in the 
list of existing templates on the right hand side of the form. 

 
• Click Next after you have made your selection. 

• Step 2 - Which data would you like to save? 
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The selections made in Step 2 answer the question, “Which data do you 
wish to save?” The choices made here determine which of the basic 
parts of your table are to be retained and if any data or formatting is to 
be saved in the template. 

• Table Components Checkboxes 
The checkboxes on the left side of the form allow you to choose which 
of the basic parts (Table Title, Subtitle, etc.) of your table you wish to 
include in the new template. Each item that is checked will be included 
in the new template.  

The Table Template Creation Wizard analyzes your table to determine which basic parts have been used in 
the original table. Only the checkboxes for parts used in the original table can be included in the template. All 
other checkboxes will be disabled. 

• Formatting 
You may choose whether or not to save the formatting for each of the 
items you have selected using the checkboxes by clicking the yes or no 
radio button next to the item that is checked. When you click on yes, 
formatting for things such as bold titles, centered column headings, and 
italicized text will be saved. 

The only settings for row and column separators that can be saved in a template are those that are set at 
table level.  This means that if all row or column separators are turned on or off in the whole table, the setting will 
be saved. Individual column or row separators will not be saved in the template.  
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• Data 
You can choose whether or not you would like your template to contain 
the same data as the original table by using the yes or no radio buttons 
in the “Keep Data” section of the form. You will be able to make this 
choice for each item that has a check in the checkbox. For instance, if 
you wish to save only the column headings in your new template, you 
would click the “yes” radio button in the “Keep Data” section for 
Column Headings but “no” for everything else. The new template 
would then have the same column headings as your original table but 
all of the cells in the table body would be empty. Table titles and 
subtitles would also be blank so you could enter new titles if desired.  

• Number of Rows 
The Rows control allows you to add more rows to your table if you 
have decided to save the data in the table body. You may add rows by 
clicking on the up arrow until the number in the box shows the number 
of columns you want or by typing the desired number of columns in the 
box. 

You can only add rows or use the same number of rows that were in the original table. This control cannot be 
used to decrease the number of rows that will be in the template. 

• Click Next if you wish to add a preview example to your 
template, or; 

• Click Finish to save the template and exit the Table 
Template Creation Wizard. 
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• Step 3 – Save Example; 

 
The Save Example button allows you to save a preview example that 
will be available through Table Creation Interface. Table examples that 
have been added can be viewed by clicking the “Example” button in 
the Table Creation form while the corresponding template is selected in 
the template drop-down menu.  

When you click on the Save Example button you will be prompted to 
navigate to the directory where the example you wish to use is stored 
on your computer or network. 

In order to add a preview example, a picture of the table in .gif or .jpg format must first have been created 
and saved. Preview examples can be added at any time after a template has been created using “Add Image to 
Template” in Template Utilities.  

• Navigate to the folder your example is stored in; 

 
• Double click on the file you wish to use for your example; 
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• Click Save; 

• Click Finish; 
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Delete A Table Template 
The delete template function will allow you to delete templates that 
you no longer wish to use. Once a template is deleted, it will no longer 
appear on the Table Type menu in the Table Creation form. 

• Select Number of Columns 

 
The Number of Columns drop-down menu will allow you to sort the 
list of templates by number of columns. Once a selection has been 
made, only the templates with the selected number of columns will be 
shown in the list of table templates. 

Select the number of columns in the template you wish to delete from 
the Number of Columns drop-down menu. 

• Click on the name of the Template you wish to delete; 

 
• Click on the Delete button at the bottom left of the form; 

 
• Click Yes to confirm your selection. 
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Add Image to Template 
Images can be added to templates at any time using the Add Image to 
Template function. This will allow you to save a preview example that 
will be available through Table Creation Interface. Table examples 
that have been added can be viewed by clicking the “Example” button 
in the Table Creation form while the corresponding template is 
selected in the template drop-down menu.  

In order to add a preview example, a picture of the table in .gif or .jpg format must have been created and 
saved first. 

To add an image to a table: 

• Select the number of columns in the template you wish to 
add an image for from the Number of Columns drop-down 
menu; 

 
• The Number of Columns drop-down menu will allow you 

to sort the list of templates by number of columns. Once a 
selection has been made, only the templates with the 
selected number of columns will be shown in the list of 
table templates; 

• Click on the name of the Template you wish to add an 
image for and then click the Add Image button.  When you 
click on the Add Image button you will be prompted to 
navigate to the directory on your computer or network 
where the example you wish to use is stored; 
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• Navigate to the folder your example is stored in; 

 
• Double click on the file you wish to use for your example; 

 
• Click Finish. 
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Export a Template 
The Export Template function allows you to share templates with 
others. When a template is exported, it is saved as an individual file 
that can be e-mailed or stored in a shared directory that other users can 
use. 

 
The Number of Columns drop-down menu will allow you to sort the 
list of templates by number of columns. Once a selection has been 
made, only the templates with the selected number of columns will be 
shown in the list of table templates. 
To export a table template: 

• Select the number of columns in the template you wish to 
export from the Number of Columns drop-down menu; 

• Click on the name of the Template you wish to export and 
then click the Export button.  When you click on the Export 
button you will be prompted to navigate to the location 
where you wish to save the file; 
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• Navigate to the folder where you wish to save the file. 

 
• Click Save.  Once you save, you will get a message 

confirming that your template was exported; 

 
• Click OK; 

• Click Close. 
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Import a Template 
The Import Template function allows you to use templates that were 
created by others.  You will only be able to import templates that have 
been created in XMetaL and that have been saved using the export 
function. (During the import process, templates are analyzed to make 
sure they are in the correct format. If the template is not a valid XML 
file, an error message will be generated.) If you do not wish to replace 
an existing template, the name of the template you wish to import must 
not duplicate the name of a template that already exists. 
To import a template: 

• Click on the Import Template button.  You will be prompted 
to navigate to the folder where the template you wish to 
import is stored; 

• Navigate to the template you wish to import; 

 
• Click on the name of the template you wish to import; 

• Click Open; 

 
• Click OK. 
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Restore Default Templates 
The Restore Default Templates function restores the initial set of 
templates to their original state. You can choose to restore only the 
templates you select or you can restore them all at once. 
The Number of Columns drop-down menu will allow you to sort the 
list of templates by number of columns. Once a selection has been 
made, only the templates with the selected number of columns will be 
shown in the list of table templates. 

Only the names of the templates that were initially provided with the application will appear on the list of 
templates that can be restored. 

To restore a template: 

• Select the number of columns in the template you wish to 
restore from the Number of Columns drop-down menu or 
select All; 

 
• Select the name of the template you wish to restore from 

the list of templates. If you have selected All from the 
number of columns drop-down, skip this step and click 
Restore; 
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• Click Restore. You will get a confirmation message to let 

you know that restoration is complete; 

 
• Click OK; 

• Click Close. 

Close 
Use the close button to exit Template Utilities. 
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Known Issues 
Incorrect Table Display 
When you first open XMetaL, tables that were previously created will 
not show the correct column widths.  
Table Displayed with Incorrect Column Widths 

 
To refresh the table so it displays correctly, change to the “tags on” 
view by clicking on the icon on the lower left hand corner of the 
screen and then click on the “normal” view icon.  
Changing your View 

 

Column Width Change When Column Type is Changed 
When text columns are changed to figure columns, the width value of 
the column must be changed to the number of digits that will appear in 
the column + 2. For example, if a text column has been changed to a 
figure column that is to contain the entry, “$1,000,000”, the column 
width value should be changed to 11. Dollar signs count as a digit and 
commas each count as a half. The total number of digits in this entry is 
9. Add 2 and the column width is 11. 
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Inserting Rows in Tables with Total Rules 
In a table such as the one below, additional rows cannot be added 
using the tab key when at the end of a row. Additional rows can be 
added in this type of table by using the Insert Row Above or Insert 
Row Below icons on the XMetaL Toolbar while your cursor is in the 
row you wish to insert a row above or below. 

 

Please note that if you insert a row directly above the row containing the total rule the new row will also 
have a total rule in the same cell as the original row. 

To insert a row that does not contain a total rule, the row insertion 
steps described above should be performed while your cursor is placed 
2 or more rows above the one containing the rule. 

 

Hidden Data 
When data takes up more space than the width of the column, text is 
sometimes hidden behind the next column instead of wrapping. This 
generally only occurs in figure columns in tables that have more than 8 
columns. 

Tables with more than 8 Columns 
Tables that have more than 8 columns will typically be displayed 
landscape instead of portrait. Another thing to keep in mind for these 
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types of tables is that there is limited space for the data. The column 
widths have been made smaller to allow the table to fit on the page and 
should not be increased or the table may not render.  

Inserting Rows in Tables Containing Spanned 
Columns 
Once a row contains a column that has been spanned, all rows that are 
added below it will also span. If rows that do not contain a spanning 
column are needed, they must be added first, and then the span added 
in the desired row. 

Copying and Pasting Tables 
Tables cannot currently be copied and pasted from one location to 
another in XMetaL. One way to work around this is to utilize the Table 
Template Creation Wizard as a means of inserting a saved table in a 
new location. If there is a table you wish to move, use the Ctrl + Shift 
+ F12 key sequence to launch Table Utilities while your cursor is 
positioned inside the table you wish to move. Click on “Create a Table 
Template” and then save your table with all data and headings. (See 
page 76 for detailed instructions on creating and saving table 
templates.) Once the template is saved it will be added to the table type 
drop-down menu on the table creation form. You may now place your 
cursor at the new location where you would like to insert the table and 
use the Ctrl + Shift + F5 key sequence to launch the Table Creation 
Interface. Select the name of the new template from the table type 
drop-down menu and click OK. The table will be inserted in the new 
location with all data and headings intact.  
If you wish to remove the template from the menu, it can be easily 
deleted using the Delete Table Template function in Table Utilities. 
(See page 84.) 

Leader Display when a Column Type is Changed 
When a column type is changed, sometimes the display of the 
associated change in leadering is not reflected in the XMetaL display 
of the table.   

Table Heading Exception 
In order to create the 2 Column Entry Table correctly, the heading was 
created as table body text that has been bolded. This means that the 
column headings checkbox in table properties will not be checked and 
that checking it will have no effect. In addition to this, the size of the 
font used for the heading cannot be changed by adjusting the heading 
point size control in table properties. 
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Row Separators in the Last Row of a Table 
When new rows are added, row separators are inherited from the 
previous row. The last row of a table is an exception to this rule 
because the horizontal rule beneath it is actually the border at the 
bottom of the table. To prevent two horizontal rules from displaying in 
the last row, no row separator is inherited when a new row is added at 
the bottom of a table. In cases where more than one row has been 
added at the bottom of the table, it will be necessary to manually turn 
row separators on in each row when row separators are needed.  

Leadering Conditions 
The following conditions apply for adding or changing leaders in a 
table. 

 
Column Type Alignment Empty Leader 
Figure\text Right Yes Yes 

 Center Yes Yes 

 Left Yes Yes 

 Right No No 

 Center No No 

 Left No Yes 

 
Last Column Alignment Empty Leader 
Yes Right Yes Yes 

 Center Yes Yes 

 Left Yes Yes 

 Right No No 

 Center No No 

 Left No No 

No Right Yes Yes 

 Center Yes Yes 

 Left Yes Yes 

 Right No No 

 Center No No 

 Left No Yes 

 
 

Header Row Alignment Empty Leader 
Yes Center Yes No 

Yes Center No No 
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Stages, Star Prints, and 
Suspensions 

Stages of legislation 
As we know, for a bill to become law it must pass both the House and 
the Senate in identical form, and then approved by the President.  
While this is a simple requirement, the procedural requirements for 
this to happen are complex.  Each introduced bill must pass through 
various stages of these procedural requirements to become law.   The 
stage attribute on the bill or resolution element (tag) indicates which 
stage the document is in. 

To set the stage 
• Select Change Bill/Resolution Stage from the LegDocMgt menu, 

or press CTRL+ALT+SHIFT+S; 

• Select correct stage from the dialog box; 

• Depending on what organization you work for your ability 
to set stages on bills may be limited. 

STAGE DESCRIPTION 
Pre-Introduction Primarily used by HOLC and SOLC in the drafting stages.

Introduced-in-House   |   Introduced-
in-Senate 

While a bill is said to be "introduced," a resolution is 
technically said to be "submitted".    For the purposes of 
XML, bills and resolutions are set to “Introduced-in-
House” or “Introduced-in-Senate” 

Agreed-to-House |  Agreed-to-Senate Considered-and-Passed-House |  Considered-and-Passed-
Senate 
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Engrossed-in-House |  Engrossed-in-
Senate 

Definition of a Engrossed Bill: “The official copy of a bill 
or joint resolution as passed by one chamber, including 
the text as amended by floor action, and certified by the 
clerk of the House or the secretary of the Senate (as 
appropriate). Amendments by one house to a measure or 
amendments of the other also are engrossed. House 
engrossed documents are printed on blue paper; the 
Senate's are printed on white paper.” [Source: 
http://www.crs.gov/products/guides/glossary/a.shtml] 

 
 

STAGE DESCRIPTION 
Enrolled-Bill |   Definition of an Enrolled Bill: “The final official copy of 

a bill or joint resolution that both houses have passed in 
identical form. An enrolled bill is printed on parchment. 
After it is certified by the chief officer of the house in 
which it originated and signed by the House Speaker and 
the Senate president pro tempore, the measure is sent to 
the president for his signature.” [Source: 
http://www.crs.gov/products/guides/glossary/a.shtml] 

Re-Enrolled-Bill  

Engrossed-Amendment-House |  
Engrossed-Amendment-Senate | 

 

Reengrossed-Amendment-House |  
Reengrossed-Amendment-Senate 

 

Reported-in-House |  Reported-in-
Senate 

 

Additional-Sponsors-House | 
Additional-Sponsors-Senate 

 

Amendment-in-House |  
Amendment-in-Senate 

 

Committee-Discharged-House |  
Committee-Discharged-Senate 

 

Failed-Amendment-House |  Failed-
Amendment-Senate 

 

Held-at-Desk-House |  Held-at-Desk-
Senate 

 

Indefinitely-Postponed-House |  
Indefinitely-Postponed-Senate 

 

Laid-on-Table-House |  Laid-on-
Table-Senate 

 

Ordered-to-be-Printed-House |  
Ordered-to-be-Printed-Senate 

 

Placed-on-Calendar-House |  Placed-
on-Calendar-Senate 

 

Public-Print  

Received-in-House |  Received-in-
senate 

 

Reference-Change-House |  
Reference-Change-Senate 

 

Referral-Instructions-House |  
Referral-Instructions-Senate 
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STAGE DESCRIPTION 
Referred-in-House |  Referred-in-
Senate 

 

Referred-to-Committee-House |  
Referred-to-Committee-Senate 

 

Referred-w-amendments-House |  
Referred-w-Amendments-Senate 

 

Sponsor-Change  

Star Prints 
When the Government Printing Office (GPO) needs to make a 
correction on a bill that is already publicly available, they will issue a 
star print. 
To set the star print: 

• Select Star print from the LegDocMgt menu; 

• Select the correct star print from the dialog box; 

• Depending on what organization you work for your ability to set 
star prints may be limited. 

Suspensions and the “Suspension Calendar” 
While there is no formal suspension calendar, sometimes the 
Congressional community uses that term when referring to the 
Speaker's list of measures that are scheduled to be considered under 
suspension of the House Rules.  Debate on a motion to suspend the 
rules and pass a measure is limited to forty minutes, and it an 
expeditious procedure for passing relatively non-controversial or 
emergency measures by a two-thirds vote of those members voting, 
with a quorum being present. The two-thirds vote simultaneously 
suspends the rules and passes the measure. If the motion is not 
supported by the required two-thirds vote, the House has not rejected 
the measure involved; it has only refused to suspend the rules in order 
to pass it. Therefore, the measure may be considered at another time 
under some other procedure. 
Suspension measures are prepared for floor action by the HOLC, and 
often the following language is printed on top of the measure, “This 
language is read by the Reading Clerk before consideration, and this 
language is not included in the enrolled\engrossed version of the 
measure.” 

To prepare a suspension measure: 
• Select Add Susp. Lang. from the LegDocMgt menu, or press 

CTRL+ALT+F5, and ; 
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• Type the required language in the suspension-floor-action and 
suspension-instructions elements (tags); 

• Print the measure. 
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Cleaning Up Documents 

Spelling/Dictionary 
XMetal contains a dictionary that is used to check and correct the 
spelling of your documents.  You can modify it by adding and deleting 
words to the XMetaL and user dictionaries. 

Spelling 
To check the spelling of your document: 

• Select Spelling from the Tools menu, or Press F7; 

• Spell checker will highlight each word it finds in the 
document with spelling errors and display a window with 
possible corrections.  Click one of the following buttons for 
each word: 
o Next moves to the next spelling error in the document; 
o Replace updates the highlighted word with the correct 

spelling; 
o Add to Dictionary adds the word, exactly as you spelled 

it, to the dictionary, 
o Ignore skips the word; 
o Restrict and Set Restriction allow you to check the 

spelling of a smaller portion of a document; 
o Cancel closes the spell checker. 
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Editing the Dictionary 
To avoid having the spell-checker stop repeatedly for terminology that 
you use regularly, you can add your own list of words to a personal 
user dictionary.   Changes to the user dictionary are saved each time 
you save the document or close XMetaL. 
To edit the dictionary: 

• Select Edit Dictionary from the Tools menu.  The Edit 
Dictionary box appears, containing a list of words in the 
current user dictionary; 

• To add a word to the dictionary, type the word in the Word 
text box and click on the Add Word button; 

• To delete a word from the dictionary, click on the word in 
the list and then click on the Delete Word button. 

Supplementary Dictionary 
A supplement dictionary for use by Congressional Users is under 
development. 

Thesaurus 
You can look up a word in your document and display meanings for 
that word using the Thesaurus.  You can also view related words such 
as synonyms, antonyms, and contrasted words. 
To look up a word in the thesaurus: 

• Highlight the word in the document you want to look up; 

• Select Thesaurus from the Tools menu, or press Shift+F7.  
The word and it’s meaning are displayed; 

• Select Synonyms, Antonyms, Related Words, Contrasted 
Words or See Also in the drop down menu; 

• A list of words is displayed below it.  Click on any word in 
that list and click one of the following buttons; 

• Next Meaning displays the definition of the word you 
selected; 

• Previous Meaning displays the definition of previously 
selected word; 

• Get Word clears the last word you selected; 

• Replace updates the document with the word you selected; 

• Cancel closes the Thesaurus. 
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The word you selected in your document is not changed until you click Replace and close the Thesaurus. 
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Tagging Terms 
You can tag terms in your document that will allow you to view all 
view where a term appears in your document using the Resource 
Manager. 
To tag terms in your document: 

• Select Set Terms from the Format menu, or press ALT+T. 
This feature will search for phrases through the document, like this: 

the term “State”  

the terms “State” and “County” 

Each time it locates a word or phrase, it will remove the quote tags and 
replace them with term tags. 

Converting hyphens to en-dashes 
You can convert hyphens to en-dashes under certain conditions.  To 
convert hyphens to en-dashes: 

• Select Set En-Dashes from the Format menu, or press 
ALT+F12.  The following conditions must exist in order for 
a hyphen to be converted: 
o When the dash joins two numerals, such as “Public Law 

107-5151”, or Figures: 5-20 (bonds); 
o When the dash joins a capital letter and a numeral, such 

as “6-A (exhibit identification)”, “DC-14 (airplane)”, 
“I-95 (interstate roadway)”, “4-H (Club)” or “Section 
12(a)-(b)”. (en dash used for the word to). 
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Final Macros 
There are two final macros that will help you prepare drafts for the 
Member or Committee office or for introduction on the House floor. 

Preparing a draft for Member/Committee: 
This macro will: 

• Hide the Member Signature line, if it is not already hidden; 

• Unhide the two “Discussion Drafts”, if there are not already 
unhidden; 

• Run the “Set Terms” function.  

• Run the “Fix En-dashes” function.   
To run this macro: 

• Select Prepare draft for Member/Committee from the Format 
menu, or, 

• Press CTRL+ALT+I. 

See Converting hyphens to en-dashes and Tagging Terms for more 
information. 
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Preparing a copy for Introduction 
This macro will: 

• Create and unhide the Member Signature line, if it is not 
present or hidden; 

• Hide the two “Discussion Drafts”, if the drafts are not 
hidden; 

• Locate all inline comments and verify how you want them 
deleted (bold brackets only, or bold brackets and the text); 

• Locate all Legis-Comments and asks you if they should be 
deleted; 

• Regenerate all Table of Contents; 

• Run the “Set Terms” function. 

• Run the “Fix En-dashes” function.   
To run this macro: 

• Select Prepare copy for Introduction from the Format menu or 
press CTRL+ALT+Y. 

See Tagging Terms for more information on Set Term functions  
See Converting hyphens to en-dashes for more information 
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Special Features 

The Resource Manager 
The Resource Manager is a tool that gives you access to many 
different things, including your desktop and your files, as well as 
information unique to the document you currently have open. 
The Resource Manager can be assessed from the View menu.  By 
default, it contains two tabs: the Assets tab and the Desktop tab.  Each 
item listed in the Assets folders can be used to navigate through your 
document by clicking on the item, as in docoutline, or insert items by 
dragging the item from the folder into your document. 
To use assets, click on Resource Manager from the View menu.  A 
window will open in XMetaL (by default, on the left-hand side of the 
screen) that has two tabs in the bottom frame.  Click on the Assets tab. 

Assets Tab: Viewing Conversion Notes 
• Click on Conversion Notes folder; 

• Click on the Generate button; 

• Move through the document by clicking on each 
conversion note; 

See Using converted XyWrite files from prior Congresses for more 
information about conversion notes. 

Assets Tab: Viewing Terms  
• Click on terms folder; 

• Click on the Generate button; 

• Move through the document by clicking on each term from 
the list generated.   

Assets Tab: Viewing Empty Enumerators 
• Click on empty-enums folder; 



Congressional Help Special Features  •  198 

• Click on the Generate button; 

• Move through the document by clicking on each level from 
the list generated.   

• Click on the current document in order to add the correct 
enumerator to the document. 

Assets Tab: Viewing Act-names.  
• Click on act-names folder; 

• Click on the Generate button; 

• Move through the document by clicking on each term from 
the list generated. 

Assets Tab: Viewing the Document Outline 
• Click on the act-names folder; 

• Select the level in which to navigate from the drop-down 
box in the left-hand side column; 

• Click on the Generate button; 

• Move through the document by clicking on the purple text 
in the directory list that was generated; 

• Close the document outline by clicking on the X in the 
Document Outline window.  

It may be necessary to press the right arrow key on your keyboard to refresh the screen after the Document 
Outline is closed. 
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Assets Tab: My Text Block 
• Click on the mytextblock folder.  A list of saved text blocks 

is displayed; 
To create a text block: 

• Use your mouse and select the text you want added to the 
text block.  If you wish to select the entire level, select the 
enum, header (if in the level) and the text, and then, click 
on Select Element from the Edit menu; 

 
• With the material highlighted, hold down the left mouse 

button and drag the text into the Personal Text Block 
frame; 
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• A dialog box appears. Enter a description for the text block 

in the Asset Details dialog box. 

 
This text will be used as the name.  You can view all the text for each 
block by holding your mouse over the block name. 

Selecting text in normal view can be misleading.  If you place your cursor in a location and use Select 
Element, only the immediate text block is selected. For the best selection of elements and text, users may find it 
easier to move material when in Tags-On view. 

To copy, delete, or rename a text block: 

• Right click on the text block name; 



Congressional Help Special Features  •  201 

 

• Select delete to remove the text block; 

• Select copy to duplicate the text block; 

• Select properties to rename the text block; 
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U.S.C. Citations 
The U.S.C. Citations program enables automated insertion of U.S. 
Code citations based on statute.  For example, after a reference to 
section 202(a)(3)(C)(iii) of the Social Security Act, the correct U.S.C. 
citation (in parentheses and including subdivisions) is inserted. 
To use the USC program: 

• Select Select Act for USC Citation insertions from the Insert menu; 

• Place the cursor at desired point of insertion. 
For the Act's name: 

o Select USC Citations…U.S. Code Act Name from the Insert 
menu, or press CTRL+ALT+SHIFT+U; 
Example: Agricultural Act of 1949 is loaded. The words 
"Agricultural Act of 1949" will be inserted. 

For the U.S. Code Cite: 

o Select USC Citations …USC Citation (for Selected 
Act) from the Insert menu, or press CTRL+ALT+U. 
Example:  

Agricultural Act of 1949 is loaded.  

Type "section 101(a)(1) of the Agricultural Act of 1949".  

The cite (7 U.S.C. 1441-1(a)(1)) will be inserted. 

To access a U.S.C. Reference via your Internet Browser: 

• Place your cursor in a U.S.C. citation,  

• Select Go to Specified Location from the Go menu, or press 
CTRL+G. 
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Math Functions 
Basic Math Formulas 
Follow steps 1, 2, and 3 to calculate basic math formulas directly in 
the text of your document. 

• Type the calculation directly in the text of your document, 
using the following symbols for the different math 
functions:  Addition - Plus sign ("+");  Subtraction - 
Hyphen ("-");  Multiplication - Asterisk ("*");  Division - 
Forward Slash ("/") 
 Example: 

1+2 

$45,350-$5,250 

128*23 

60,000/22 

(10*((120+34)/2)) 

 

• Type the Equal Sign ("=") after the formula. 
Example: 

1+2= 

$45,350-$5,250= 

128*23= 

60,000/22= 

(10*((120+34)/2))= 

• With the cursor located to the right of the Equal Sign ("="), 
press    ALT + the Equal Sign ("="). The answer will 
appear immediately after the Equal Sign. 
Example: 

1+2=3 

$45,350-$5,250=$40,100 

128*23=2,944 

60,000/22=2,727.2727272727 

(10*((120+34)/2))=770 
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Adding/Subtracting Numbers One-by-One 
Single numbers may be added or subtracted in XMetaL. Follow steps 
1, 2, and 3 to add and subtract numbers directly in the text of your 
document. 

• Place the cursor to the right of the first number, and press 
ALT+Plus Sign ("+") (to add) or ALT +Minus Sign ("-") (to 
subtract).  

You must use the plus ("+") or minus ("-") sign on the numeric keypad. 

• Place the cursor to the right of the second number, and 
press ALT+Plus Sign ("+") (to add) or ALT+Minus Sign ("-") (to 
subtract).  

• Moves the cursor to the location where you want the final 
answer placed, and press ALT+Equal sign ("="). 

Windows Calculator 
Instead of using the two methods above, you may use the Windows 
calculator to perform math calculations. (In Windows, go to Start, 
Programs, Accessories, Calculator.) 
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Internal Cross-References 
XMetaL has the ability to create and check internal cross-references.   
Internal cross-references are defined here as internal to the document 
you are working on.  For example, you could be referring to subsection 
(c) from text in subsection (a).  There are three reasons to identify 
internal cross references using the Alt+X macro: 
 

• It is faster than typing the text (e.g., subsection (c)). 
• The cross references can be automatically checked later in the 

process improving drafting quality and efficiency.  For 
example, if you have removed subsection (c) or created a new 
subsection (c) and the “original” subsection (c) becomes 
subsection (d), the cross reference check will notify you of the 
change, and help you correct the cross reference automatically. 

• The cross references will allow you (and the public) to navigate 
the document more rapidly by placing your cursor in the 
“subsection (c)” text and pressing Ctrl+G. 

The Simple Example 
To create a cross reference to subsection (c) from subsection (a), place 
your cursor in the text of subsection (a) and type a space, followed by 
the letter “c”, followed by Alt+X, 
The cursor will move to subsection (c) and a message will appear on 
the screen asking you to confirm whether this is the right spot or not.   

 If it is the correct level (where the cross reference is referring 
to), simply press Enter.  The cursor will automatically return to 
the spot you were at in subsection (a) and the words 
“subsection (c)” will be typed in automatically. The text will 
appear in a different color (green at this time).  Pressing Ctrl+G 
while your cursor is within the “green” text will allow you to 
navigate immediately to subsection (c).  To return to the cross 
reference, press Ctrl+Shift+G. 

 If the Alt+X macro did not take you to the correct level, the 
message that appears on the screen will give you the option to 
choose “No” because this is not the correct cross-referenced 
level.  In this case, you will need to move the cursor to the 
correct level and press the Alt+Shift+X key in order to generate 
the link to the correct location.  Once you press Alt+Shift+X, the 
cursor will return to the location in subsection (a) and the 
words “subsection (c)” will appear automatically as described 
above. 

 The typing of the letter “c” alone will be referred to as the “shortcut” of the target, there will be much more 
information on this later. 
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Occasionally, you may want to add the phrase “of this section” or “of 
this subsection” to the cross reference text.  There are two ways to 
have the “of this …” added automatically.  If you had type a semi-
colon (;) after the shortcut, the resulting cross reference would have 
included the “of this…”  The second way to accomplish this is by 
simply pressing Alt+X immediately after the cross reference is created 
(e.g., after the text “subsection (c)” appears.  Because the cursor is 
next to the cross reference, it will know to add the correct “of this…” 
to the text.  
Cross references without shortcuts 
Since we often copy and paste text from emails and word processing 
files, it is also easy to cross-reference this material without having to 
create shortcuts.  Simply highlight the text “subsection (c)” and press 
Alt+X.  If there is a subsection (c) within the current section, the macro 
will act the same as though you had typed the shortcut; the enumerator 
of subsection (c) is highlighted and you will be asked to confirm the 
location.  Once confirmed, the subsection (c) will become a cross 
reference and shown in green.  The macro will read and understand 
more complex forms (e.g., “paragraph (1)(B) of section 4(c)”) and 
successfully find the right location. 
More complex examples 
As you know, cross-references are just not as simple as a reference to 
subsection (c) from subsection (a), both in terms of their relative 
location and the text they generate.  As a result, the customization 
provides for several levels of complexity, including a manual 
approach.  Let us discuss the completely manual approach first so you 
can understand how there is always a way to create a cross-reference, 
then we will look at several shortcuts based on your typing the shortcut 
form target. 
Manual approach 
Let us say you have some arbitrary text you want to represent as a 
cross reference: it could be some text like “that subsection” or a form 
that cannot be generated from the shortcut form.  To create this cross 
reference, first highlight or select the text you wish to establish as the 
source of the cross reference, in this case “that subsection.”  Then, 
simply press Alt+X.  The macro recognizes that you have selected text 
that it does not understand as the source of a cross reference.  A 
message will appear that tells you to move the cursor to the cross 
reference location and press Alt+Shift+X to establish the cross reference.  
After you have dismissed the message by pressing Enter, you should 
move your cursor to the correct location and press Alt+Shift+X.  The 
cursor will return the text you highlighted and mark it as a cross 
reference to the appropriate level. Again, Ctrl+G will allow you to 
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navigate to the target of the cross reference and Ctrl+Shift+G will take 
you back. 
In addition, once the cross reference text is established, you can 
always change or add material to that text.  For example, you may 
want to add the words “of this section” to the cross reference text 
“subsection (c)” by placing your cursor inside the “xref” element.  If 
the text appears in the cross reference color (e.g., green), the text is 
part of the cross reference. 
Referencing Big Levels 
Let us say you want to create a cross reference Title III.  Simply type 
“t;iii” and then press Alt+X.  The words “Title III” will appear and the 
cross reference will be created automatically (without checking).  The 
characters before the “;” character, tell the macro the level.  If you 
want to reference “this title”, simple type “t;” followed by pressing 
Alt+X.  Note: the casing of the enumerator will be uppercased 
automatically.  The following table shows the characters to type on the 
left side of the “;” and the text that will be generated: 
d Division 
t Title 

st Subtitle 

c Chapter 

sc Subschapter 

p  Part 

sp  Subpart 
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Inside Text and Inside Quoted-Blocks 
One problem involving cross reference location involves whether the 
cross reference is within a quote or not.  The key to figuring this out is 
based on the location of the source text.  If you are inside a quoted 
block, the internal cross reference is most likely to material in the 
current quoted block.  The rules remain the same as above and the 
Alt+X macro will only look inside the current quoted-block by default.  
Similarly, when your cursor is outside of quoted block material, the 
cross reference is likely to not be in quoted block material, so the 
default is to check outside of quoted-block material.  However, cross 
references to levels within quoted blocks do occur.  To tell Alt+X that 
the cross reference is within a quoted block, simply start the shortcut 
with “q:”.  So, in our simple example above, if the cross reference to 
subsection (c) was inside a quoted block, you would have typed “q:c” 
before pressing Alt+X, rather than typing “c” by itself.  Of course, you 
will be asked to confirm the location, so even if you can’t remember 
this, you can still achieve the results you need. Note: the macro will 
check the following quoted-block and then the preceding quoted-
block.  It does not search through all quoted-blocks within the 
document. 
Shortcut Form 
The shortcut form enables you to type the reference cryptically to 
achieve the desired result.   Let’s say you want to reference “section 
4(a).”  You can simply type “4a” and then use the Alt+X macro.  If you 
want to reference “subsection (a)(3)”, you would type “a3”.  This 
approach frees you up from typing all those parentheses and the level 
type.  For example, “4a3BiiIV” will produce “section 
4(a)(3)(B)(ii)(IV)”.  If you need to reference section 4(1), you would 
use “4.1”.  The period is used to separate the section from the 
paragraph enumerators.  It’s generally a good idea to type a period 
after the section enumerator all the time because of the conflict with 
paragraph enumerators.  This is particularly true when trying to 
reference a section alone. 
We also need to deal with language such as “subsection (a) of section 
4.”  To accomplish this, the shortcut would be “4.,a”.  “4.a,1” would 
be turned into “paragraph (1) of section 4(a)”.  A more complex 
example would be “103.,c,6” which would be turned into “paragraph 6 
of subsection (c) of section 103”  If you want the text to use the form 
“of this…”, you would add a “;” to the end of the shortcut.  For 
example, “a3;” would produce “subsection (a)(3) of this section”, 
“6,B;” would produce “subparagraph (B) of paragraph (6) of this 
subsection”, and “b2,A;” would produce “subparagraph (A) of 
subsection (b)(A) of this section”. 
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The macro actually searches the enumerators of the levels based on 
your shortcut and where your cursor is located by first seeing if the 
reference is contained within the level you’re at and then searching up 
through the document.   
Of course, if you or the macro makes a mistake, you can always 
simply edit the text as you need. 
Where Are the References to This Level? 
On occasion, you may want to know where there are cross references 
to the level you’re in.  For example, you want to delete the level or 
you’re just curious.  Simply press Alt+Y at any level and a message box 
will tell you the levels that contain cross references to the level your 
cursor is in.  But, don’t worry about fixing the cross references 
manually.  The Cross Reference Checker will do that for you. 
Checking Cross References 
At any point while editing a document, you can check the document’s 
cross references for accuracy.  While you edit the document, cross 
referenced levels can (1) remain correct, (2) be moved (e.g., new 
levels are inserted, preceding levels are deleted, etc.) and thus the 
target levels change their enumeration, or (3) be deleted. 
The Cross Reference Check macro reviews all of the cross references 
in the document and only reports the problems and suggests automated 
corrective action.  For example, if there was a cross reference to 
subparagraph (A) which became subparagraph (B), the macro would 
give you the following three choices:  

 Change the text and link to subparagraph (B) (the default), 
 Reset the link to the current subparagraph (A), 
 Re-enter the cross reference short-cut. 

Whenever a cross reference is created, two pieces of information are 
stored with the cross reference source: (1) the unique id for the cross 
referenced level and (2) the legislative path for the level (which is 
made up of the enumerators leading to that level from the section level 
to the current level).  The unique id stays with that level even if the 
enumerator or text changes and even if the level is cut and pasted 
somewhere else into the document.  When a level is copied, the 
original level maintains the original unique id and the pasted level gets 
a new id.  By using the unique ids and the enumerator path, the cross 
reference check is able to determine if the level being cross referenced 
is still the same as originally created. 
One technical point:  When cross referenced levels are deleted, the 
document technically contains an XML illegal condition.  If you use 
the XML Validator, the document is not valid at the time you delete 
the level.  To resolve this problem, whenever you save the document, 
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all broken links are automatically assigned to the legislative body of 
the document.  This enables the document to be valid for saving and 
enables you to continue working without checking the cross references 
all the time.  When you check the cross references, the macro will 
report all cross references to the legislative body as broken links and 
provide you with appropriate options.  
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Appendix A – FAQ  

Frequently Asked Questions 
How do I type text? 
For ease and efficiency, you should type in sentence-style casing 
throughout the document, particularly in the headers. The casing of the 
headers in the final typeset document will be printed correctly. The 
advantages of typing headers in sentence style are clear: 

• No need to think about the correct casing for each level; 

• When levels are moved during drafting, the casing will not 
need to be "fixed"; 

• Tables of contents can be automatically generated without 
adjusting the casing of the table of content entries. 

What is this lime green text? 
Hidden text, or text that will not print, appears in lime green.    Our 
XML files use this hide feature so one file can represent all versions 
(introduced, enrolled, engrossed, reported, etc) of the resolution or bill. 
My cursor, and the text, scrolled to the left while I was typing.  
How can I fix this? 
This is a display problem.  To bring the text, and the cursor, back into 
view on your screen press the left arrow key until the screen is 
displayed correctly. 
I would like to change section text into Subsection (a).  How do I 
do this? 

• Place your cursor in the Section text; 

• Press CTRL+1.  The Section text will be converted to 
Subsection (a) and a Subsection (b) will be added. 

It is easy to see how to insert a new section at any point in a bill after 
the first section. But it is not clear how you would insert a new section 
before the first section. 
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• Place your cursor in the header of Section 1(right before the 
first letter in the first word); 

• Press CTRL+0.  A new section should be inserted and the 
original Section 1 will become Sec. 2.  Depending on how 
Section 1 needs to look, you may need to use CTRL+H and 
CTRL+T to add/remove header and text. 

How do I change SEC. to SECTION? 

• Place your cursor in the section header of the section you 
need to change.; 

• Select Set Section Type from the Format Menu; 

• Select option two, "Section-ONE type". 
When I merge a file, do the enumerators get redesignated 
automatically? 
No.  The enumerators are not redesignated automatically when you 
merge multiple files into one document.  This was done by design. 
How do I make a change to the short title? 

• Select Short Titles from the Insert menu or press 
CTRL+ALT+Q.  This will display a dialog window that 
contains all the short titles in your document; 

• Edit your short title and click OK.  The short title should be 
changed wherever it appears in the document. 

How do I insert flush left text? 

• Place the cursor in the last level before the location of the 
flush left text; 

• Press CTRL+SHIFT+F, or select flush-left text from 
Section-and-below levels on the Insert menu. Note the 
location of the flush-left text. It is important that it is 
aligned with the correct level. Hit CTRL+SHIFT+F 
repeatedly to move the text in or out. 

I am drafting in traditional style.  Why aren’t the headers for the 
sections centered on screen? 
While drafting in traditional style, the headers for sections will not 
appear centered on the screen; although the headers will print centered 
on the PDF.  At this time, there is no available technical solution to 
display section headers centered on the screen. 
To assist the drafter, gray generated text indicating the style of the 
quoted block appears at the beginning of the quoted block.  When 
drafting in traditional style, it reads as follows: [Style of Quoted-
Block: traditional]. 

See the section, Drafting Legislative Styles, for more information. 
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How do I get rid of quotes [the tag]? 

• Place your cursor inside the quote and right-click with your 
mouse; 

• Select untag from the drop-down menu.  The quote tags 
should be removed. 

How do I change a paragraph into a subsection?  
Place your cursor inside the paragraph and use the promote feature: 

• Select Promote Level from the Format menu, or press 
ALT+SHIFT+P. 

How do I get a list of the archive file names associated with my 
document?  
To view information about the current document, including archive 
file names and dates: 

• Select Document Information from the File menu.  This 
is a text file and it may be printed. 

When saving as Locator Codes (XyWrite), if I go to another program 
(by using the Windows task bar), the Save As Locator Codes dialogue 
box disappears *behind* the main window, but the main window 
cannot be activated (or minimized), because there is an open dialogue 
box. 
Try minimizing all open windows first, and the "Save As Locator 
Codes" dialogue box will be refreshed and "appear" again.   
To minimize all open windows: 

• Using your right mouse button, click a blank area on the 
taskbar; 

• Click Minimize All Windows. 
To restore your windows to their original state: 

• Use your right mouse button to click a blank area on the 
taskbar; 

• Click Undo Minimize All. 
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Appendix B – Deviant Quoted 
Block Styles 

Drafting the Railroad Retirement Act and Chapter 110 of 
Title 18 in XML. 
 
The Railroad Retirement Act of 1974 can be drafted in traditional quoted block style and Chapter 
119 of Title 18 of the U.S. Code can be drafted in USC quoted block style.  The enumerators follow 
a different pattern than the standard OLC, USC and Traditional styles.  Users will have to manually 
type the correct enumerator in the first level of a series or turn off  the auto-rededesignate feature in 
the User preferences and manually renumber the enumerators.  Excerpts are below 
 

The Railroad Retirement Act of 1974 

 
XMetaL (left-hand side) -----  PDF from HOLC Comps files (right-hand side) 
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XMetaL (left-hand side) -----  PDF from HOLC Comps files (right-hand side) 

 
Chapter 119 of Title 18 of the United States Code 

 
XMetaL (left-hand side) -----  PDF from HOLC Comps files (right-hand side) 
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XMetaL (left-hand side) -----  PDF from HOLC Comps files (right-hand side)  
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Glossary of Terms 

cascading style sheets (CSS) 
A way to show a document.  XMetaL uses cascading style sheets to format the XML 
document in Normal and Tags On views.  The CSS is what allows the display to be 
in different colors, sizes, indentations, etc. 

Context Area 
The area to the left of the horizontal scrollbar, at the bottom of the XMetaL 
document window.  It displays the name of the current element/tag and all of its 
ancestors. 

DTD (Document Type Definition) 
A DTD (or a document type definition) is a file which defines what tags and 
attributes are used to describe content in an XML document, where each tag is 
allowed, and which tags can appear within other tags.  For instance, in the 
Congressional bill DTD, section tags are allowed inside of a Title tag, but Title tags 
are not allowed inside subitem tags. 

element 
Elements are the building blocks of any XML document. Blocks of text are 
contained inside elements.  An element in an XML document begins with a start-tag 
and ends with an end-tag.  Start tag for the element official-title: <official-title>  End 
tag: </official-title> 

generated text 
Text that is generated by a display program (rather than being part of the document 
content).  The enacting clause is one example of generated text in an XML House 
bill. 

Hopper  
A box on the clerk's desk in the House chamber into which members deposit bills 
and resolutions to introduce them. To "drop a bill in the hopper" is to introduce it. 
(Source: http://www.crs.gov/products/guides/glossary/h.shtml) 
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IDs and IDRefs 
IDs are unique identifiers for parts of an XML document.  The valud of an ID 
attribute must not be used for any other ID attribute in teh documetns.  IDREFs refer 
back to IDs.  The value of an IDREF attribute must be the value of an ID attribute 
somewhere in the document.  IDREFs do not have to be unique. 

Legislative Styles 
As defined by Lawrence Filson in the book, The Legislative Drafter's Desk 
Reference, "'Drafting style' is the term used to describe the external characteristics of 
legislative language, and has nothing to do (directly) with what that language does or 
how the bill as a whole is organized."    

Level 
A level is a generic term referring to a unit of the legislative body in a bill or 
resolution.  Section, Subsection, Paragraph, Subparagraph, Clause, Subclause, Item 
and Subitem are levels.  A contains an enumerator, followed by an optional header 
and an optional  text.  Title, Subtitle, Chapter, Subchapter, Part and Subpart are big 
levels. 

Measure 
A bill, joint resolution, concurrent resolution or simple resolution.  Bills and joint 
resolutions are legislative measures; simple and concurrent resolutions are 
nonlegislative measures. (Source: 
http://www.crs.gov/products/guides/glossary/a.shtml) 

Notepad 
Notepad is a basic text editor you can use for simple documents. The most common 
use for Notepad is to view or edit text (.txt) files.  

To print a Notepad document:  On the File menu, click Print, then on the General 
tab, select the printer and options you want, and then click Print. . 

Quoted Block 
A quoted block is a series of levels that are quoted as opposed to a quoted phrase 
within text.  Quoted blocks generally contain amendatory language. 

tags 
An element in an XML document begins with a start-tag and ends with an end-tag.  
Start tag for the element official-title: <official-title>  End tag: </official-title> 

Text-Insert Markers 
Markers used to assist the drafter when authoring a document in XMetaL.  These 
markers are gray in color and contain a description surrounded by curly braces. 
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XMetaL 
Software application that edits XML documents.  The planned replacement for 
XyWrite. 

XML 
Extensible Mark-up Language.   XML is a markup language for documents 
containing structured information.  XML is an initiative of the W3C; for more 
information, see http://www.w3.org/XML. 

XyWrite 
The current DOS-based editor used by the Legislative Branch to create and edit 
legislative documents. XMetaL is the planned replacement for XyWrite. 

 


